Recently I've been trying to get my adafruit 2.8 inch touchscreen to work with Kali Linux 2.1.2 for the raspberry pi 2.
Unfortunately i ran into a confusing couple of errors, this is all after configuring the screen to work with the pi and successfully running it with the screen twice.

The Pi boots normally and the screen runs through several lines of start up commands but stops at emergency mode.
Personally i don't know why this is as it only started after two boots of the pi normally (with the adafruit kernel installed).
However to run in default mode it says to type Control D.
Afterwards it runs through more setup until it stops at an error with the line:

failed to start ... root device.
see 'systemctl stat...ice' for more detail.
Without touching it it proceeds to a command line login with the lines:
Kali GNU/Linux Rolling kali ttyl
i perform the login for the root account and again it stops on after testing the wlan input, after searching online i found i could start the GUI manually with
but attempting this only leads to an error in:
mktemp: failed to create file via template '/tmp/serverauth.XXXXXXXXXX' : Read-only file system
xauth: error in locking authority file
xauth: timeout in locking authority file /root/.authority
I used several guides online such as starting
deleting the file
Furthermore i have tried all suggestions on this link:

Again this is on kali linux any help would be well recieved.

Sincerely Koronter