Results 1 to 1 of 1

Thread: Help with LCD interface resolution and Wireless on FriendlyArm NanoPi S2 Kali 2.1

  1. #1
    Join Date

    Help with LCD interface resolution and Wireless on FriendlyArm NanoPi S2 Kali 2.1

    I recently received my NanoPi S2 with an LCD add-on ( The board is an ARM board made around the Samsung Quad Core Cortex-A9 S5P4418 SoC.

    I found out that there were two kali images available for the board. One was provided by friendlyarm and the other one by kali. The one provided by them worked perfectly with the screen despite its odd resolution 1024x600 but the Wifi was not working. I tried using an external wireless card but the same thing. In the network device list none of them appeared.

    The board has an onboard Ampak AP6212 module which it includes a Broadcom BCM43438 and the usb one is a Ralink RT5370. With the image provided by kali the Wifi was working correctly, both the wireless cards are recognized by the os and I can use them to connect to my home network.

    The only problem with the one provided by kali is that the lcd interface is not working correctly, the max resolution is 800x480 and there are some strange images on some parts of the screen. I attached some pictures to show my problems. In the picture with the name "No wifi cards" you can see that despite the fact that the usb wireless card is plugged in and lsusb detects it kali says that there are "No network devices available", this is with the image provided by friendlyarm. In the image "Screen not working with kali image" you can see the lcd interface not working correctly whereas in the image "Screen working with friendlyarm image" you can see how the lcd should look like.
    The command lsb_release -a on both of them return:
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: kali-rolling
    Codename: kali-rolling

    Most of the commands in the Wifi Troubleshooting page do not return anything in the friendlyarm image and the rest of them are not present in the os.

    On the firendly arm image "uname -a" returns:
    "Linux kali 3.4.39-FriendlyARM #7 SMP PREEMPT Mon Feb 22 17:49:01 HKT 2016 armv7l GNU/Linux"

    On the image provided by kali "uname -a" returns:
    "Linux kali 3.4.39 #5 SMP PREEMPT Thu Mar 17 15:31:53 CDT 2016 armv7l GNU/Linux"

    Is there any way I can make the image work as it should? I would like to have the lcd working as it works on the friendlyarm image and I would like to have the wifi working as on the kali image. Can anybody please help me? Thank you.
    Attached Images Attached Images

Similar Threads

  1. No wireless card interface while plugging in USB wireless adapter
    By xyq96999 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-09-15, 05:31
  2. Kali 2.0 - Wireless interface fall always
    By juanvelasco in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-08-26, 17:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts