Results 1 to 10 of 14

Thread: Wireshark segmentation fault

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Feb 2015
    Posts
    6

    Wireshark segmentation fault

    I'm getting a Wireshark seg fault when I tried to execute the application today.

    System fully updated running in VMWare 12.1.
    Host is Windows 10 Home x64

    This is a Kali 2016.2 XFCE version with the awesome g0tmi1k post install script. Machine running great for the last 12 months.

    Details:
    Code:
    [root:/]# uname -a
    Linux kali 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux
    [root:/]# cat /etc/*-release
    DISTRIB_ID=Kali
    DISTRIB_RELEASE=kali-rolling
    DISTRIB_CODENAME=kali-rolling
    DISTRIB_DESCRIPTION="Kali GNU/Linux Rolling"
    PRETTY_NAME="Kali GNU/Linux Rolling"
    NAME="Kali GNU/Linux"
    ID=kali
    VERSION="2016.2"
    VERSION_ID="2016.2"
    ID_LIKE=debian
    ANSI_COLOR="1;31"
    HOME_URL="http://www.kali.org/"
    SUPPORT_URL="http://forums.kali.org/"
    BUG_REPORT_URL="http://bugs.kali.org/"
    [root:/]# cat /proc/version 
    Linux version 4.6.0-kali1-amd64 (devel@kali.org) (gcc version 5.4.0 20160609 (Debian 5.4.0-6) ) #1 SMP Debian 4.6.4-1kali1 (2016-07-21)
    [root:/]# cat /etc/issue
    Kali GNU/Linux Rolling \n \l

    Here's the gdb backtrace:

    [root:~/Downloads]# gdb /usr/bin/wireshark
    GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
    Copyright (C) 2016 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law. Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-linux-gnu".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://www.gnu.org/software/gdb/bugs/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from /usr/bin/wireshark...(no debugging symbols found)...done.
    (gdb) run
    Starting program: /usr/bin/wireshark
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
    [New Thread 0x7fffe1352700 (LWP 90217)]
    [New Thread 0x7fffdb7fd700 (LWP 90218)]
    [New Thread 0x7fffdaffc700 (LWP 90219)]
    [New Thread 0x7fffd8e36700 (LWP 90223)]
    [New Thread 0x7fffd17c7700 (LWP 90224)]
    [New Thread 0x7fffd0fc6700 (LWP 90225)]
    [New Thread 0x7fffcbfff700 (LWP 90226)]

    Thread 1 "wireshark" received signal SIGSEGV, Segmentation fault.
    0x00007ffff0ab175b in wtap_encap_string () from /usr/lib/x86_64-linux-gnu/libwiretap.so.6
    (gdb) bt
    #0 0x00007ffff0ab175b in wtap_encap_string () from /usr/lib/x86_64-linux-gnu/libwiretap.so.6
    #1 0x00007ffff445af9d in ?? () from /usr/lib/x86_64-linux-gnu/libwireshark.so.8
    #2 0x00007ffff4ccf38f in register_all_protocols () from /usr/lib/x86_64-linux-gnu/libwireshark.so.8
    #3 0x00007ffff4172868 in ?? () from /usr/lib/x86_64-linux-gnu/libwireshark.so.8
    #4 0x00007ffff414ddc7 in epan_init () from /usr/lib/x86_64-linux-gnu/libwireshark.so.8
    #5 0x00005555556a26fa in main ()
    (gdb)
    Already tried to remove and resintall with no luck.

    Any idea what to try?

    Thanks a lot.
    Last edited by hopes; 2017-03-18 at 07:53 AM. Reason: Added system details as per the rules

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •