Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: SOLUTION: Kali Linux on Raspberry Pi Zero W with bluetooth and wifi support

  1. #11
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    The nexmon drivers that come with the kernel are for the Pi3 only. I'm working on a new release that includes the drivers for the Pi0 as well but that might take a few more days.
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  2. #12
    Junior Member
    Join Date
    Dec 2016
    Posts
    20
    Ok, I installed the image today. I did update & upgrade and i have still 1 package on upgradable list:
    Code:
    root@kali:~# apt update
    Hit:1 http://kali.koyanet.lv/kali kali-rolling InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    1 package can be upgraded. Run 'apt list --upgradable' to see it.
    root@kali:~# apt list --upgradable
    Listing... Done
    bluez/kali-rolling 5.43-2 armel [upgradable from: 5.39-1+rpi1+re4son]
    N: There is 1 additional version. Please use the '-a' switch to see it
    How to upgrade this package? After apt upgrade/dist-upgrade/full-upgrade nothing happens.

    PS. Great job Re4son! I'm waiting for new realase.
    Last edited by martinii; 2017-07-20 at 07:14 PM.

  3. #13
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    Thanks for your kind words and don't worry about that message.

    The re4son-kernel installs a unique bluez version that I patched especially for the on-board bluetooth chip of the Pi 3 & Pi 0W.
    The installer puts the package on hold so that future kali updates can't replace it with a generic debian version.
    That's what the message points out.

    Bluez 5.39-1 is the latest version I could make to work with the hardware and there doesn't seem to be any reason to go for a later version at this stage anyway.
    FYI, the raspbian implementation is based on Bluez 5.23-2 so we are well ahead of them
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  4. #14
    Junior Member
    Join Date
    Dec 2016
    Posts
    20
    Ok, thanks for explanation.

    And how about new version of the image? When you planning to release it?

  5. #15
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    I've updated both, the 4.4.50 and the 4.9.24 versions of the re4son-kernel. Highlights of this release are:

    - Natively compiled, incl. headers for rock solid out of tree driver compilations on your Raspberry Pi
    - Nexmon drivers for Raspberry Pi 3 and Raspberry Pi 0W included, fully compiled and ready to use

    Hop over the the re4son-kernel page and grab your copy while it's still hot:

    https://whitedome.com.au/re4son/re4son-kernel/

    Happy hacking
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  6. #16
    Junior Member
    Join Date
    Dec 2016
    Posts
    20
    Great news! Thanks!

  7. #17
    Junior Member
    Join Date
    Dec 2016
    Posts
    20
    I get this error:
    Code:
    Jul 27 08:09:54 [localhost] kernel: [   23.625608] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
    Jul 27 08:09:54 [localhost] kernel: [   23.627517] brcmfmac: brcmf_add_if: ignore IF event
    Jul 27 08:09:54 [localhost] kernel: [   23.638264] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    And than my RPI0W hangs and i must reset it...

  8. #18
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    These messages are normal with the 4.4 kernel and disappear in 4.9.
    They can't cause your system to hang though.
    Anything else abnormal? Any additional hardware or so?
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  9. #19
    Junior Member
    Join Date
    Dec 2016
    Posts
    20
    You are right. I got this error too:
    Code:
    Jan 17 09:36:19 wpa_supplicant[1168]: wlan0: CTRL-EVENT-SCAN-STARTED 
    Jan 17 09:36:20 wpa_supplicant[1168]: wlan0: WPA: Group rekeying completed with 10:fe:ed:79:85:56 [GTK=CCMP]
    Jan 17 09:38:19 wpa_supplicant[1168]: message repeated 119 times: [ wlan0: WPA: Group rekeying completed with xx:xx... [GTK=CCMP]]
    Jan 17 09:38:19 wpa_supplicant[1168]: wlan0: CTRL-EVENT-SCAN-STARTED
    Tho solution was to set WPA/WPA2 Group Key Update Period to 86400 in my wifi router.

  10. #20
    Junior Member
    Join Date
    Aug 2017
    Posts
    2
    I've tried registering at your forums, re4son, but for some reason I've not received a confirmation email. So I figured I'd register here and ask my question.

    I'm using the pre-made re4son-kernel image found on your website. Not the sticky-fingers release, because I am not using a TFT screen of any kind. I'm using my television and a Raspberry Pi 3. Everything works great and it really is faster than standard Kali+Nexmon drivers. Great work!

    My problem is that after performing the steps found on your website for copying over the Nexmon driver and installing nexutil (found in the nexmon.txt file), I can enable monitor mode exactly once. As soon as I use "nexutil -m0", the card does not enter monitor mode again. Likewise, after a reboot while in monitor mode, the card will not enter monitor mode again. Instead I see the following in my terminal:

    nex_init_netlink: socket error (93: Protocol not supported)
    nex_init_netlink: socket error (93: Protocol not supported)
    nex_init_netlink: bind error (9: bad file descriptor)
    nex_init_netlink: connect error (9: Bad file descriptor)
    ERR (__nex_driver_netlink): no valid answer received
    Thinking I'd just redo the steps, I redid the steps found in the nexmon.txt file and then went here https://github.com/seemoo-lab/nexmon and did the following:

    Find the path of the default driver at reboot: modinfo brcmfmac #the first line should be the full path
    Backup the original driver: mv "<PATH TO THE DRIVER>/brcmfmac.ko" "<PATH TO THE DRIVER>/brcmfmac.ko.orig"
    Copy the modified driver: cp /home/pi/nexmon/patches/bcm43438/7_45_41_26/nexmon/brcmfmac/brcmfmac.ko "<PATH TO THE DRIVER>/"
    Probe all modules and generate new dependency: depmod -a
    The new driver should be loaded by default after reboot: reboot
    Note: With this setting, you can toggle between Monitor mode and Managed mode with: nexutil -m2 and nexutil -m0
    Note: It is possible to connect to an access point using our modified driver and firmware, just set the wireless interface in Managed mode.
    But it didn't help. I still see the original error. Using the image and Win32DiskImager to remake the image on my 64Gb SD card allows me to use monitor mode exactly once, again. Any clue whats going on?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •