Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: Executing 'grub-install dummy' failed.

  1. #31
    Junior Member
    Join Date
    Feb 2018
    Posts
    7
    Quote Originally Posted by _defalt View Post
    I followed your steps in that thread however I still got the same error as mentioned before:
    20180205_191719.jpg

  2. #32
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    865
    Quote Originally Posted by jyde2077 View Post
    @ _default,

    So I ran into something very similar to this issue with dual booting win10. I think I know where my issue kinda is. My system is below.

    Toshiba Terca c50
    Win10 on 1st hard drive
    Kali on 2nd hard drive mount is /dev/sdc efi partition is /dev/sdc1
    other specs
    CPU core i5
    RAM 8 gigs

    When I ran the installer I didn't pick the 3 option with all the different mount points I chose the 2nd option with just the ..../home. When I ran the command mount --bind /dev /mnt/dev I get the error mount: mount point doesn't exist. Should I run re run the installer or is there a fix for this also? Sorry if that doesn't make any sense. Please let me know if you need more info on my system or steps I took.


    jyde2077
    What is the partition name of your kali filesystem? You mounted the wrong partition in the first command.

  3. #33
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    865
    Quote Originally Posted by emmodunne View Post
    I followed your steps in that thread however I still got the same error as mentioned before:
    20180205_191719.jpg
    Before attempting my given solution, run modprobe efivarfs.

  4. #34
    Junior Member
    Join Date
    Feb 2018
    Posts
    7
    Quote Originally Posted by _defalt View Post
    Before attempting my given solution, run modprobe efivarfs.
    I ran
    modprobe efivarfs
    .

    This returned
    modprobe: ERROR: could not insert 'efivarfs': No such device
    Attached Images Attached Images
    Last edited by alexertech; 2018-02-07 at 02:59 AM.

  5. #35
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    865
    Try modprobe efivars

  6. #36
    Junior Member
    Join Date
    Feb 2018
    Posts
    7
    Quote Originally Posted by _defalt View Post
    Try modprobe efivars
    I got the same error:
    modprobe: ERROR: could not insert 'efivars': No such device

  7. #37
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    865
    This error only occurs if UEFI is disabled and Legacy BIOS is enabled. Make sure this is not the case.

    Use rufus to create a bootable USB and 2018.1 image is out. If there was a bug with the earlier image it would have been fixed in this recent image.

    Interesting it is not happening with me.

  8. #38
    Junior Member
    Join Date
    Feb 2018
    Posts
    7
    Quote Originally Posted by _defalt View Post
    This error only occurs if UEFI is disabled and Legacy BIOS is enabled. Make sure this is not the case.

    Use rufus to create a bootable USB and 2018.1 image is out. If there was a bug with the earlier image it would have been fixed in this recent image.

    Interesting it is not happening with me.
    I verified that UEFI Boot is enabled and Legacy Boot is disabled:
    20180215_143304.jpg

    I had installed the image 2017.3 so as you advised I downloaded the 2018.1 image and made a bootable usb using Rufus. However, during the install I got the following error:
    20180215_143428.jpg

    Kali Linux does not seem to like me

  9. #39
    Junior Member
    Join Date
    Feb 2018
    Posts
    7
    I managed to overcome the error I mentioned above. However, grub dummy still fails to execute even with the new image. Maybe I am missing something regarding boot settings - I have posted a picture of those settings above.

    Thank you for all your help

  10. #40
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    865
    No your boot settings are perfectly fine. I will look into the issue.

    grub-dummy error during the OS installation happens when grub bootloader is already present in the EFI partition so installer can't overwrite it.

    You can delete the old grub by mounting the EFI partition and delete the grubx64.efi in /mnt/EFI/kali. It's a critical solution. One mistake can prevent windows to boot.

    Boot into kali-live and mount EFI partition as:
    mount /dev/sda1 /mnt
    nautilus /mnt/EFI/kali


    Use fdisk -l to list which one is your EFI partition. It may not be /dev/sda1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •