Results 1 to 11 of 11

Thread: Kali installation stuck at Install the GRUB boot loader on a hard disk

  1. #1
    Join Date
    2013-Jul
    Location
    Karachi, Pakistan
    Posts
    4

    Kali installation stuck at Install the GRUB boot loader on a hard disk

    I am doing encrypted disk installation. First partition is /dev/sda1, mount point is /boot and it is unencrypted and second partition /dev/sda2, mount point / and it is encrypted partition. Whole installation went fine but stuck at Install the GRUB boot loader on a hard disk. It's not going anywhere from here. No movement in progress bar.
    See the image http://imgur.com/TnkmPRP

  2. #2
    Join Date
    2017-May
    Posts
    1
    I am having the same problem . I get thru installing system and gets to point of updating grub and hangs. It asks if i want to add to current jessie debian 8 system on laptop but want to have it load thru USB stick on its own. Any advice would be helpful. JUst tryign to simple installation without encryption or persistence. just hangs at 66 %

  3. #3
    Join Date
    2017-May
    Posts
    5
    I am having the same issues. Mine only installs all the way when my Nvidia GPU is active but then it won't boot. If GPU disabled then the grub boot loader gets stuck.

  4. #4
    Join Date
    2017-May
    Posts
    5
    I fixed my issue by installing Kali by having my Nvidia GPU on, after installiation I turned my GPU off and used my intel's GPU and it then successfully booted into Kali. After that I installed Nvidia's drivers and then turned my Nvidia back on

  5. #5
    Join Date
    2017-Jun
    Posts
    3
    From the looks of unanswered post on this forum I decided to try the IRC support channel. After 36 hours waiting I gave up. So here goes:

    I downloaded the kali-linux-2017.1-i386.iso, dd-ed it to usb. Used the graphical install on a old desktop-pc as a single OS as “guided - use entire disk” and it got stuck on “updating grub”
    On the same machine again but now I set up the partitions manually. Same result. Again, now I used “install” instead of “graphical install”. Same result.

    I did this on a Aspire one mini-laptop. Same result. and finally on a fairly new Aspire (6gig ram, q-core) and again i get same result.

    This “updating grub” freeze at 66% is not new and goes back a decade in other distros. I did not find a solution in this forum or anywhere. I greatly appreciate some help.

    Anton

    Oh sorry I forgot, it was a encrypted install.
    Last edited by aantoonio; 2017-06-07 at 18:16.

  6. #6
    Join Date
    2017-Jun
    Posts
    3
    Today i downloaded the kali-linux-xfce-2017.1-amd64.iso, thinking it was only the 32bit version of at error. I installed it to the fairly new Aspire (6gig ram, q-core). I did a guided full disk install with encryption. FAIL. Then I partitioned the disk manually, sda1 for boot, swap encrypted and root encrypted. Both FAILED at the exact same 66% at "updating grub". I could sure use some help here.

    Anton

  7. #7
    Join Date
    2017-Jun
    Posts
    3
    I figured it out, thanks for the help

  8. #8
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    924
    Quote Originally Posted by aantoonio View Post
    I figured it out, thanks for the help
    Post your solution.

  9. #9
    Join Date
    2017-Aug
    Posts
    1
    Same thing Encrypted install.
    What I did to fix the install I just preformed I opened a new terminal with "CTRL+ALT+F3" Hit space-bar
    Typed in ps | grep -i grub
    I kill the last two processes... they where the same. " os-prober " After killing them both using kill pid
    I went back to the install terminal. 'CTRL+ALT+F5'
    The install will fail. I then used back button to select install grub. All went well after this. Hope this helps I will try and reedit the post if I run into this again.
    Last edited by int96; 2017-08-09 at 19:40. Reason: remembered something!!p

  10. #10
    Join Date
    2017-Sep
    Posts
    2
    Quote Originally Posted by int96 View Post
    Same thing Encrypted install.
    What I did to fix the install I just preformed I opened a new terminal with "CTRL+ALT+F3" Hit space-bar
    Typed in ps | grep -i grub
    I kill the last two processes... they where the same. " os-prober " After killing them both using kill pid
    I went back to the install terminal. 'CTRL+ALT+F5'
    The install will fail. I then used back button to select install grub. All went well after this. Hope this helps I will try and reedit the post if I run into this again.
    This helped me go back to the main kali installer menu. Still stuck on the grub installer. Deleted, re-partitioned and installed Kali. Thanks for this!

  11. #11
    Join Date
    2017-Sep
    Posts
    2
    Quote Originally Posted by _defalt View Post
    Post your solution.
    I also figured out that if you continue to run sa test my network part of the installation procoess, make sure that you are connected to the internet. Tried and tested.

Similar Threads

  1. GRUB Boot Loader Not installing on Hard Drive
    By jalil md desa in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2017-09-29, 08:45
  2. GRUB Boot Loader Not installing on Hard Drive
    By D3ATHMWH in forum Installing Archive
    Replies: 8
    Last Post: 2017-07-27, 00:59
  3. Can not boot from hard disk without 'super grub disk2'
    By sm0ker in forum Installing Archive
    Replies: 1
    Last Post: 2014-09-07, 15:22
  4. Replies: 0
    Last Post: 2014-01-27, 14:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •