Results 1 to 8 of 8

Thread: No grub after installing kali alongside windows

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    5

    No grub after installing kali alongside windows

    Hey all

    I'm new here, and i can't get kali to work. After installation, it just loads Windows 10. I have tried for many hours not getting it to work, here is my latest steps:

    Changed BIOS->Boot to "Legacy"
    Booted Windows 10 installation, deleted all partions, and choosed to install windows on the unallocated space.
    After windows 10 first start, i shrinked C: volume by 50GB, so i now have the partions for windows and 50GB unallocated space
    I then booted into Kali, choosed "Graphical install"
    At one of the first points, i get "Can't mount and detect CD-ROM drives"
    I fixed this by going to the shell typing: "mount -t vfat /dev/sdb1 /cdrom" and continued the installation
    I choosed "Guided - use the largest unallocated space" and i let kali set up the partions
    When asked for where to install grub i choosed dev/sda (Windows)
    And after reboot it just boots windows or if i open boot menu, my only options is USB HDD or HARD DRIVE, and choosing harddrive also just boots windows

    A'm i doing something wrong? Why can't i boot into Kali after a clean install?

    Sorry for my bad English. Any help would be much appreciated

    Specs:
    - Using Windows 10 Pro x64 - Made USB-install media by formatting USB to FAT32 and unpacked win10.iso from microsofts homepage
    - Using Kali Linux 2016.2 x64 - Made Live-USB using Rufus (MBR and UEFI)
    - On a laptop, Acer TravelMate P276, Model: ZYW
    - The only error message i get is: "Can't mount and detect CD-ROM drives", and is fixed by mounting the USB device on CD-ROM
    Last edited by mijaysen; 2017-04-22 at 01:51 PM. Reason: Wrong brand name of laptop

  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    798
    When you run windows 10 do you boot it in UEFI or Legacy BIOS?

  3. #3
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    I guess it was Legacy due to i changed the bios setting to Legacy prior to booting windows 10 -> Opened BOOT MENU -> Choosed USB HDD

    BUT it looks like UEFI when it boots (I had UEFI windows 10 before clean install). Any way to make sure its installed in Legacy?

  4. #4
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    798
    Go to your Boot settings and see whether UEFI is enabled or Legacy BIOS is enabled. Windows 10 doesn't support Legacy BIOS. It doesn't boot if it is enabled so I think you are booting it in UEFI. You installed kali in Legacy mode which was unnecessary. So if you want to boot kali you have to switch from UEFI to Legacy but then windows 10 won't boot. Then you have to switch from Legacy to UEFI for Windows 10 but then Kali won't boot.

    This is the reason why Legacy BIOS sucks. I wish if it was become obsolete to use it for kali.

  5. #5
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    BIOS boot setting is still on legacy, and windows 10 boots normally, but no grub

  6. #6
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    798
    Boot into kali live and run these commands:

    mount /dev/sda* /mnt
    mount --bind /dev /mnt/dev
    mount --bind /proc /mnt/proc
    mount --bind /sys /mnt/sys
    mkdir /mnt/hostrun
    mount --bind /run /mnt/hostrun
    sudo chroot /mnt
    mount --bind /hostrun/lvm /run/lvm
    grub-install /dev/sda
    sudo update-grub
    exit
    umount /mnt/dev
    umount /mnt/proc
    umount /mnt/sys
    umount /mnt/hostrun
    umount /mnt


    Replace * in sudo mount /dev/sda* /mnt with your linux filesystem name. Like mine is /dev/sda6

  7. #7
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    798
    I still don't know what was your point of switching to Legacy mode. Before installing Windows10 and kali the first thing you did was change boot settings to Legacy. Do you know what Legacy mode is used for?

  8. #8
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    Quote Originally Posted by _defalt View Post
    I still don't know what was your point of switching to Legacy mode. Before installing Windows10 and kali the first thing you did was change boot settings to Legacy. Do you know what Legacy mode is used for?
    The reason why i used Legacy, is becuse i couldnt boot kali in UEFI mode, with serval methods of making the USB media, so i decided to use legacy only (Did not know windows 10 not works on legacy). When you told me windows 10 wont boot in legacy even thru' it looks like legacy in BIOS, it proberly boots from UEFI, so i tried to google why i couldnt boot kali in UEFI, and found an article about booting UEFI linux on Acer, wich is very strange. What i had to do was, making an UEFI bootable kali live USB (Downloaded 3 UEFI files from fedora 23, modded to work on Kali put in folder EFI/boot/ on USB), went into BIOS with USB connected, set a supervisor password, change BOOT to UEFI, and enable secure boot. Now go to security, and "Selecting an UEFI File as trusted for executing" -> Choosed EFI file i downloaded earlier onto USB, now i disabled secure boot again, saved changes, and i am now able to boot UEFI kali. After install i can now choose between KALI, WINDOWS, or USB, by going to the boot menu.

    Thank you very much for your help and time. You send me in the right direction

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •