Results 1 to 10 of 10

Thread: Problem when booting Kali after Dual boot install

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    5

    Problem when booting Kali after Dual boot install

    Hello, My name is agnivesh and I'm new to both Kali and this forums, Sorry in advance for any mistake in the way i posted this thread

    I installed the 2017.1 version of Kali linux 64 Bit alongside my windows 10 (Asus Rog laptop),

    During the Installation stage I was asked to load missing non free firmwares (listed below as failed to load firmwares) So i downloaded them and continued with the setup and installed sucessfully .But after boot

    But after booting When I click Kali 64amd to boot in it shows a console type window with the error message

    Code:
    iwlwifi 0000:02:00.0: firmware: Failed to load iwlwifi-8000c-25.ucode (-2)
    Code:
    iwlwifi 0000:02:00.0: firmware: Failed to load iwlwifi-8000c-26.ucode (-2)
    Code:
    iwlwifi 0000:02:00.0: firmware: Failed to load iwlwifi-8000c-24.ucode (-2)
    Code:
    iwlwifi 0000:02:00.0: firmware: Failed to load iwlwifi-8000c-23.ucode (-2)
    Code:
    Bluetooth: hci0: Failed to send Intel_Write_DDC (-22)
    Code:
    nouveau 0000:01:00.0:DRM : Pointer to TMDS table invalid
    Code:
    nouveau 0000:01:00.0 DRM:Pointer to flat panel table invalid

    After displaying this message the screen freezes.After refering lots of sites i found the problem was with Nvidia driver .But none of their solutions worked (maybe because i can't acess the internet due to the failed iwlwifi firmwares) .Please help


    System Specs : Windows 10
    Intel Wireless adapter
    Nvidia gtx 960 M graphics card
    Intel HD Graphics
    Ram 16 gb


    20170429_170822.jpg

  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    810
    iwlwifi is the proprietary drivers of Intel Wireless Family. You can download those missing drivers and copy them in /lib/firmware. But these missing drivers are not the problem.

    The problem is with the nvidia drivers. Follow this guide to install nvidia drivers.
    Last edited by _defalt; 2017-04-30 at 12:07 PM.

  3. #3
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    Quote Originally Posted by _defalt View Post
    iwlwifi is the proprietary drivers of Intel Wireless Family. You can download those missing drivers and copy them in /lib/firmware. But these missing drivers are not the problem.

    The problem is with the nvidia drivers. Follow this guide to install nvidia drivers.


    Where do i enter this code , (Since I'm a begginer and the OS won't boot)

    How do I install the firmware without Booting into kali (since i can't)
    And will the Nvidia driver method work since I have no internet connectivity(because of the firmware

    Thanks in advance
    Last edited by agniveshsp; 2017-04-30 at 03:59 PM.

  4. #4
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    810
    You can use LAN and those commands have to be entered in the terminal.

  5. #5
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    Quote Originally Posted by _defalt View Post
    You can use LAN and those commands have to be entered in the terminal.
    I can't go into the terminal , since i can't boot kali .The screen freezes after displaying the error.Please help

    UPDATE:
    I tried to enter the code by booting into recovery mode . but when i enter the first line
    lspci | grep -E "VGA|3D"

    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
    0a:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 850M] (rev a2)
    The cursor keeps blinking ,And lets me type anything i want .
    Last edited by maiki; 2017-05-01 at 08:45 AM. Reason: Merge posts

  6. #6
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    810

  7. #7
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    Thanks man , I took your advice on booting into root shell and used a live linux boot device to boot into the terminal , I don't know what i did next . I just googled and started copying and pasting codes form random site into the terminal and it worked . Thanks a lot

  8. #8
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    810
    You should have posted a solution how you did it.

  9. #9
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    This is what i can remember , I followed a yutbe video upto the part where he mounts the drive and removes grub using a linux live disc

    Then I searched for my problem on nvidia driver , THen i copied and pasted every bits of code i saw and then when i restarted the firmwares were still working but I booted in successfully

  10. #10
    Junior Member
    Join Date
    Oct 2013
    Posts
    2
    i fixed also following this manual, thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •