Results 1 to 2 of 2

Thread: Help with nmcli and connecting to specific bssid (error 53)

  1. #1
    Join Date

    Help with nmcli and connecting to specific bssid (error 53)


    I am attempting to use the network manager command line interface to connect to a specific wifi network by BSSID. There are multiple wifi networks within range with the same SSID, so I am attempting to use the BSSID to connect to the specific network.

    I found the specific BSSID by using the following nmcli command.
    nmcli -f chan,ssid,bssid,signal,security dev wifi
    The response looks similar to this.
    4 | network0 | xx:xx:xx:xx:xx:xx | 67
    6 | network1 | xx:xx:xx:xx:xx:01 | 64
    6 | network1 | xx:xx:xx:xx:xx:02 | 50
    6 | network1 | xx:xx:xx:xx:xx:03 | 43
    6 | network1 | xx:xx:xx:xx:xx:04 | 40
    You'll notice the reason for my specifying a bssid, as the situation involves choosing an ap amongst many with the same SSID, operating on the same channel with varying levels of signal strength.

    Upon attempting to connect to a specific network with the following command:
    nmcli d wifi connect xx:xx:xx:xx:xx:01
    I receive this error message, despite the network having sufficient signal.
    Error: Connection activation failed: (53) The Wi-Fi network could not be found.
    I'm unable to find much information on this particular error message after reading the nmcli man page and searching significantly on Google and various forums.

    For what it's worth, I am able to successfully connect to another wifi network (e.g. network0 in the above list) using the same command.

    Does anybody know why I'm having a problem connecting, and how to potentially resolve the problem?

    Thank you.

    Possibly pertinent information:
    Wifi Adapter: AWUS036NH

  2. #2
    Join Date
    This is what i do
    1) Check your interface
    sudo nmcli dev status
    2) Scan for your PA
    sudo nmcli dev wifi list

    3) Create the profile for your connexion
    sudo nmcli con add con-name <My_profile_name> ifname <My_interface> type wifi ssid <My_eSSID>
    4) Enable WPA to enter your key
    sudo nmcli con modify <My_profile_name> wifi-sec.key-mgmt wpa-psk
    5) Enter your key
    sudo nmcli con modify <My_profile_name>  wifi-sec.psk <My_WiFi_WPA_key>
    6) Connect with the profile to your PA
    sudo nmcli connection up <My_profile_name>
    7) Check it
    sudo nmcli -p c

    Job is done!

Similar Threads

  1. Replies: 2
    Last Post: 2016-09-29, 16:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts