Results 1 to 2 of 2

Thread: Setting up RPi 3 B

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    3

    Setting up RPi 3 B

    I'm really not sure where to post this, as it seems more like a general Linux question but for me it pertains to Kali
    Please move and/or inform me if this is wrong, thanks.

    So essentially I'm trying to accomplish these goals:

    -Install Kali on a Raspberry Pi 3 Model B (I've done this with both of the files in the downloads ARM section, I assume the 2/3 option is correct as the other made it so none of the USB ports function)

    -Setup headless mode. Auto login, SSH, blah blah.

    -Make it so wlan0 is an ad-hoc network from startup so I can SSH from my phone/pc/laptop.

    Now I can do all of this just fine with the default Raspbian image, and Kali 2 on my laptop. But when it comes to the Pi everything starts to mess up, from USB ports not working, auto login not working, auto connection to wifi not working. What makes it worse is most of these problems seem seriously inconstant, usually going away after starting from scratch and reappearing upon rebooting.

    Can anyone help with this? Sorry if it seems nooby but I just don't know what's going on.

    Here's all the things I change upon starting, thanks for any help:

    Code:
    Changing the boot mode to command line-
    Set Console- "systemctl set-default multi-user.target"
    
    Setting up Auto Wifi connection-
    wpa_supplicant.conf- 
    
    "network={
      ssid="my network name"
      psk="my network password"
      proto=RSN
      key_mgmt=WPA-PSK
      pairwise=CCMP
      auth_alg=OPEN
    }" 
    
    Interfaces-
    "auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf"
    
    Doing whatever this does, I suspect this isn't even necessary for a fresh build
    "update-rc.d -f ssh remove" 
    "update-rc.d -f ssh defaults"
    
    And auto login-
    /etc/lightdm/lightdm.conf- Uncomment autologin and timeout
    EDIT: Sorry for double posting, clicked the button before realising my mistake
    Last edited by Sunstarx55; 2017-05-09 at 10:39 AM.

  2. #2
    Junior Member
    Join Date
    Dec 2016
    Posts
    3
    So I managed to dig up a PS2 to USB connector and do all I did above directly on the Pi instead of editing it first on my laptop. This seems to have made a difference, the only thing that's not working now is the auto login. Not too much of a problem, just for temporary convenience.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •