Hello all, I am having issues installing VB 5.1 on my kali 8.8 (jesse) system. I tried running apt-get upgrade and receive this error message

root@Kali:~/Downloads# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
virtualbox-5.1 : Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
Depends: libqt5x11extras5 (>= 5.1.0) but it is not installed
Depends: libsdl1.2debian (>= 1.2.11) but it is not installed
Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
Depends: libvpx1 (>= 1.0.0) but it is not installable
Recommends: libsdl-ttf2.0-0 but it is not installed
Recommends: linux-image but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I have ran apt --fix-broken install and keep getting this message

root@Kali:~/Downloads# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
empathy empathy-common espeak-data firebird2.5-common firebird2.5-common-doc
gdebi-core geoclue-2.0 gnome-dictionary gnome-mime-data gnome-packagekit
gnome-packagekit-data gnome-screenshot gnome-system-log gstreamer1.0-nice
hwdata imagemagick-common iproute libbonobo2-0 libbonobo2-common
libboost-atomic1.61.0 libboost-chrono1.61.0 libboost-date-time1.61.0
libboost-filesystem1.61.0 libboost-system1.61.0 libboost-thread1.61.0
libcamel-1.2-57 libchamplain-gtk-0.12-0 libchromaprint0 libcrypto++6
libedataserver-1.2-21 libespeak1 libfarstream-0.2-5 libgadu3 libgdict-1.0-10
libgdict-common libgeos-3.5.0 libglew1.13 libgnome-2-0 libgnome2-common
libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgupnp-igd-1.0-4
libicu55 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libladr4
liblircclient0 liblouis10 libmeanwhile1 libmimic0
libmission-control-plugins0 libmysqlclient18 libnice10 libnm-glib-vpn1
libnm-gtk-common libnma-common libopencv-contrib2.4v5 libopencv-legacy2.4v5
libopencv-ml2.4v5 liborbit-2-0 libosinfo-db libperl5.22 libpoppler61
libprotobuf-c1 libprotobuf9v5 libpurple-bin libpurple0 libradare2-0.9.9
libschroedinger-1.0-0 libtelepathy-farstream3 libvpx3 libwebkitgtk-1.0-0
libwebkitgtk-3.0-0 libwildmidi1 libx265-79 libzephyr4 pidgin-data prover9
python-clamd python-cluster python-d2to1 python-darts-lib-utils-lru
python-defusedxml python-esmre python-git python-gitdb python-guess-language
python-halberd python-ipaddr python-ndg-httpsclient python-nltk
python-pdfminer python-phply python-ply python-psutil
python-pybloomfiltermmap python-pycryptopp python-pygithub python-pypdf
python-ruamel.ordereddict python-smmap python-soappy python-stopit
python-svn python-tblib python-vulndb python-webkit python-wstools
python-xdot telepathy-gabble telepathy-haze telepathy-logger
telepathy-mission-control-5 telepathy-salut w3af w3af-console
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 155 MB disk space will be freed.
Do you want to continue? [Y/n]

after clicking Yes it deletes these files but i think the apt-get update is bringing them back. I have tried googleing these errors but it basically just says to update and upgrade. Thank you in advance for the solution to this issue. Please let me know if any further info can be provided.