Results 1 to 2 of 2

Thread: Troubleshooting a LibreOffice5.3 install

  1. #1
    Join Date

    Troubleshooting a LibreOffice5.3 install

    I installed LibreOffice5.3. By the looks of the terminal output, the install looks to have been successful. But, I don't see any added icons for LibreOffice when I go to: Desktop > Applications > Usual applications > Office, like the readme file says will appear upon successful installation. So then I go back and take a look at one of the online articles that I found previously, located at "". It tells me to try the "libreoffice5.3" command if I have trouble launching LibreOffice. I try that command but all I get is about a 0.5 second view of a spash-type screen (it only takes up a fraction of the screen and then disappears) followed by the terminal outputting "Kernel library file /usr/share/pocl/kernel-i686-pc-linux-gnu.bc doesn't exist." Then a prompt follows that.
    I look around online some more and find an article where the author didn't get any icons either after an install, but was able to run specific apps from the terminal. So, as described, I run the "/opt/libreoffice5.0/program/oosplash –calc" command to see if a spreadsheet app appears. The terminal shows me an output of "bash: /opt/libreoffice5.0/program/oosplash: No such file or directory".
    Well, now I'm starting to think that I may have messed things up pretty good. You see, at first, before installing the "Linux x86 (deb)" file option, I didn't know which option to choose and went (mistakenly I guess) with the "Linux x86 (rpm)" option. I didn't know that it was the wrong option until I had read (after the initiall install) the readme file's section on something like [Installing LibreOffice on version such as Fedora using the rpms packages]. But after I did the initial install with the *.rpm file, the terminal complained with all sorts of errors which is why I figured that I still had a chance, and it's also (in combination with seeing that section in the readme file) when I realized that I needed to go back and get the *.deb version instead.

    So, now I'm not sure what I should do. I've put some variations of the error message in Google, and also searched for other scenarios of users who were having similar issues, but I've come up empty. I'd imagine that if it's possible, I want to use the terminal to remove everything that's related to LibreOffice so that I can start again fresh, and give the "Linux x86 (deb)" install another try. Only I don't know the commands for that (if it's possible). Any suggestions?


    I was just browsing the Community Generated HowTo's on these forums and glancing at the thread title "Installing Java on Kali-Linux" and thought to add that before doing any of the two LibreOffice installs, I installed the JRE first. I didn't really know if it was necessary or not, but figured that it was better to do it just in case.

    Two screenshots are attached ("scrntp.png" & "scrnbtm.png"), to give an idea of how the 2nd attempt at an install went, when I tried the install with the "Linux x86 (deb)". I don't have the output for the 1st try ("Linux x86 (rpm)") because I closed the terminal window before I knew that I needed a screenshot of it.

    Other details: Kali 2017.1 (w/ GNOME? - 32bit); it's a USB live w/persistence installation.

    !!!! Edit: I'm not sure why the pics that I attach are downsized. That's never happened on other forums. Is there a process that I should do to pics that I attach on these forums - like maybe resize them %400 or something like that?

    !!!! Edit2: This link is to the same pics that're attached, only they are of a legible size (
    Attached Images Attached Images
    Last edited by aptpupil; 2017-05-13 at 11:51. Reason: The pics become too small after attaching...
    Give a man a fish and you feed him for a day. Don't give a man a fish and feed yourself instead. He's a grown man. And fishing's not that hard.

  2. #2
    Join Date
    I have same problem also like this, did u fix it yet? Can i know how to ?

Similar Threads

  1. MSFCONSOLE troubleshooting
    By Youcef in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-08-25, 09:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts