Results 1 to 3 of 3

Thread: bash: ifconfig: command not found!!!

  1. #1
    Join Date

    bash: ifconfig: command not found!!!

    Right, so basically I have installed kali Arm img onto a raspberry pi 3, its a complete scratch install, and immediately upon logging in it's throwing this bash error, I took a look in /sbin, and ifconfig is not actually in there, so i ran update, and install-kali-full, and after checking all up to date and rebooting, still no ifconfig, i understand i can just run apt-get install ifconfig, but I am coming across this issue with a couple of other commands I've tried... any help?

  2. #2
    Join Date
    The debian guys have superseded ifconfig just to keep us on our toes Try "ip a" instead.
    If you want to resist evolution, you can get it back via

    sudo apt install net-tools
    Hope that helps
    Last edited by re4son; 2017-05-17 at 10:01.

  3. #3
    I don't understand what is going on in the brain of the GNU-Linux developers lately. Since system.d everybody is loosing mind.
    Now to bring up an interface, instead of
    ifconfig <interface> up
    You are supposed to do
    ip link set dev <interface> up
    And about the interface naming: in kali we use "the old fashioned way" which is deprecated too
    If we would follow system.d recommendations and default naming scheme, an USB wifi interface would be something like "wlx00c0ca849eac" (wlx + mac of the device)
    So in an up to dated and non deprecated wway, turning up my wifi USB would be something like this
    ip link set dev wlx00c0ca849eac up
    instead of the old supered way
    ifconfig wlan1 up
    I love progress, it makes life much easier

Similar Threads

  1. bash: apt... command not found
    By grimy1928 in forum TroubleShooting Archive
    Replies: 8
    Last Post: 2017-11-11, 16:30

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts