My Kali Version: 4.9.0-kali4-amd64


I have a card NVIDIA 9500 GT And I install the Drive : nvidia-legacy-340xx-kernel-340.102

VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1) (prog-if 00 [VGA controller])
	Flags: bus master, fast devsel, latency 0, IRQ 27, NUMA node 0
	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at dc00 [size=128]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100] Virtual Channel
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Kernel driver in use: nvidia
	Kernel modules: nvidia
When I try to download this package "libgl1-nvidia-glx-i386" the apt-get require to download many other drivers that I dont need, and if I accept their will to corrupt my driver.
But I need this package to make a Program Works. how can I install this package without to corrupt my drive?

Here are this driver when I try to get apt-get

root@kali:~# apt-get install libgl1-nvidia-glx-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-nvidia-glx-i386:i386 : Depends: libgl1-nvidia-glx:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Apt get update :
Hit:1 sana InRelease 
Hit:2 kali-rolling InRelease
Reading package lists... Done 

apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.