Results 1 to 4 of 4

Thread: Alfa AWUS036H cannot discover WIFI networks

  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    2

    Question Alfa AWUS036H cannot discover WIFI networks

    Hello All

    I am running Kali 2017.1 on virtual box. So far I have tried 3 wireless cards to the machine. Kali is detecting my wifi cards completely fine. The issue is at first Kali can not discover any wifi for 5-10 minutes.e1.jpg. After a while it does discovers the wifi networks, but it gives error when connecting to it. Fainal.jpg. To add on, I successfully tried my card on monitor mode, sniffing packets, and also launched a deauth. attack on my dummy/test device.

    I noticed the MAC of my wifi card is changing alot in Kali and randomly without me changing it. Could this be an issue?

    I tried all the forums, tutorial videos etc. to look for a fix, but unfortunately I guess, this is a unique problem maybe?. Thank you.

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    685
    How does your Alfa work outside a VM? Personally, I've always found VMs problematic when doing wireless work.

  3. #3
    Junior Member
    Join Date
    May 2017
    Posts
    2
    Quote Originally Posted by grid View Post
    How does your Alfa work outside a VM? Personally, I've always found VMs problematic when doing wireless work.
    Hi Grid. My card works perfectly fine outside VM on host. It is simple plug n play for me on my host.

  4. #4
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    685
    I have that same model Alfa card, and on a non-VM, it works great. Plug-n-play, like you said.

    I'd say the problem is with the VM itself, or VirtualBox. Have you contacted VirtualBox support?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •