@_defalt Sorry for the late reply but I was trying other methods. Actually, my laptop is fairly new so I thought maybe if I try a newer release of kali would it work?... and it did. I downloaded kali-linux-2017.3-amd64 and booted from that. The setup did not stop at grub and it installed successfully past all the grub-install dummy step.

But now another problem rose. My wifi adapter is not being read. In the settings in the wifi tab it says wifi not supported. A key note:
*During installation an error came about some missing firmware files. It said: Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable media, such as a USB stick or floppy.
The missing firmware files are: rtl_nic/rtl8168h-2.fw
If you have such media available now, insert it, and continue.
Load missing firmware from removable media? (yes/no)

Also at the network configuration step, the setup is supposed to first scan for lan0 and then wlan0. But during my setup, it scanned lan0 and skipped wlan0. Since I dont have means for LAN connection I had no choice but to choose for configure network later.

After the installation, I connected my phone through tethering and did a apt-get update and apt-get dist-upgrade. It fetched around 1.1GB of data but still no luck. I searched online and heard about backports. But during installation, there was a step which used "make unload" command which gave an error about the linux headers are not installed or missing.
To overcome this, i did a apt-cache search linux-headers and installed the ones corresponding to my version(using uname -r). They got installed but still no luck with the make command.

Sorry for such a long error post but I just think maybe you could connect all these problems. Also I dont think the kali image is corrupted as I installed kali in another laptop using the same image and it worked like a charm.