Results 1 to 6 of 6

Thread: Kali, Rap Pi, wireless USB and wlan0

  1. #1
    Join Date

    Kali, Rap Pi, wireless USB and wlan0

    Sorry folks, but it HAS been a long time.

    I have a RPI 2B and tried to get it working with a different USB wifi dongle.
    The drivers couldn't be installed. Dunno why, but that's an OLD problem.

    Since then, I have bought an "official" wifi/wireless USB dongle and started again with Kali.

    I had a lot of fun getting it updated to THE latest version, but it seems to be now so.
    I log on and browse to a "how to crack a WPA-2 key" walk through.

    It starts off with the command:
    ifconfig wlan0 up
    iwlist wlan0 scanning

    And so it goes on.

    There is no wlan0 on the machine.

    lsusb yields a wierd device name - which is the USB wifi thingy.
    Something like Te234c8....

    Hey, it is on the other machine and this is not my KALI pi.

    AFAIK, this machine has a wlan0 thingy, but no wifi dongle, so it just isn't used.

    Searching I found something about "it has been depricated and now called backport"

    It Sounds like a big headache for nothing...
    Compact-wireless is deprecated since a long time, it is now called "backport".

    But I think that is not exactly what I am talking about anyway.

    So if the "walk throughs" reference wlan0 and mine doesn't have one, what am I missing?

    Oh, and then it (the first link) goes on to talk about mon0..... Doing the commands listed before but with the appropriate changes to the device (from wlan0 to the "real" one) I don't get a mon0 either.

    I get another wierd name.

    Sorry, but it seems just beyond me.

  2. #2
    Join Date
    Then replace wlan0 by the interface name on your system. Did you know that there are tutorials on Follow those tutorials, they have been tested a lot:

    Just FYI, compact-wireless never existed, it was called compat-wireless (then linux-backports). And they haven't been updated in ages, so that means if you installed the latest version, you would downgrade your wireless drivers.

  3. #3
    Join Date
    I shall have to power up my KALI machine.

    From the link you mentioned:
    rausb0 Ralink RT73 rt73
    wlan0 Broadcom b43 - [phy0]
    wifi0 Atheros madwifi-ng
    ath0 Atheros madwifi-ng VAP (parent: wifi0)

    There is no wlan0....... I don't understand what is going on or why.

  4. #4
    Join Date
    Now on my KALI machine, this is where the problem/s start:

    kali:~$ sudo ifconfig
    [sudo] password for Columbo:
    enxb827ebba844b: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet netmask broadcast
    inet6 2001:8003:2a25:3800:911e:6343:f36f:39b4 prefixlen 64 scopeid 0x0<global>
    inet6 fe80::fea6:f112:acd6:a01b prefixlen 64 scopeid 0x20<link>
    ether b8:27:eb:ba:84:4b txqueuelen 1000 (Ethernet)
    RX packets 164 bytes 20801 (20.3 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 162 bytes 17083 (16.6 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet netmask
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 0 (Local Loopback)
    RX packets 160 bytes 12960 (12.6 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 160 bytes 12960 (12.6 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    wlx40a5efd2eb55: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 40:a5:ef:d2:eb:55 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    enxb827ebba844b: is eth0:
    wlx40a5efd2eb55: is wlan0:

    I didnĀ“t give them those names.

  5. #5
    Join Date
    Oh and just as a quick extra bit of information:

    sudo iwconfig
    [sudo] password for Columbo:
    wlx40a5efd2eb55 IEEE 802.11bgn ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry short limit:7 RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off

    lo no wireless extensions.

    enxb827ebba844b no wireless extensions.

    Still no wlan0:
    Last edited by security nut; 2017-06-07 at 22:18. Reason: smilies all over the place

  6. #6
    Join Date
    Hi security nut,

    just disable persistent interface names by adding
    net.ifnames=0 biosdevname=0
    to your "boot/cmdline.txt".
    That should do the trick.

    Hope that helps,

Similar Threads

  1. Installing wlan0 on Kali Linux using compact-wireless
    By satishcse in forum General Archive
    Replies: 7
    Last Post: 2016-04-07, 17:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts