Results 1 to 5 of 5

Thread: kali linux 2017 continuosly disconnecting from wifi

  1. #1
    Junior Member
    Join Date
    Jun 2017
    Posts
    1

    kali linux 2017 continuosly disconnecting from wifi

    I have installed kali 2017..and using Lenovo laptop having rtl8821ae wifi card.I have dual boot of windows 10 and kali linux .When i am connecting it with wifi it is working,webpages are loading but suddenly webpages getting stop loading.it is disconnecting from wifi and it is happening in every 5 to 15 minutes after 5 and the i have to reconnect it but in windows there is no problem.I have installed the Network drivers but that did not solve my problem.If you need any further details plz inform me i can give yu any kind of information.can anyone help me plz....
    Last edited by Arijit1080; 2017-06-11 at 06:57 AM.

  2. #2
    Junior Member
    Join Date
    Jun 2017
    Posts
    3
    I am facing the exact same problem.

    I had already been looking in the forum for a solution but nothing worked until now.
    To solve it I tried the following:
    1. edit "/etc/resolv.conf" and changed nameserver from "192.168.0.1" to "8.8.8.8".
    2. edit "/etc/NetworkManager/NetworkManager.conf" and changed "managed=false" to "managed=true".

    My current workaround is to run "service network-manager restart" but as I have to do it every few minutes it's kind of a mess.

  3. #3
    Junior Member
    Join Date
    Jun 2017
    Posts
    2
    I'm also having this issue however mines not even generating the nameserver did you figure out a better fix for it?

  4. #4
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    573
    To all,

    Have you ruled out any hardware problems (i.e. router, ISP, etc)? Anything nearby causing signal interference?

  5. #5
    Junior Member
    Join Date
    Jun 2017
    Posts
    3
    While this happens I am still connected to my router and can access its web interface. Only my Kali stick is facing this problem, other devices run fine. So the router (DNS) configuration should be fine.

    Right now I am using this script as dirty workaround. It will restart the network-manager if I am loosing connection:

    #!/bin/bash

    while true;
    do
    echo "Check if connected..."
    x=`ping -c1 google.com 2>&1 | grep unknown`
    if [ ! "$x" = "" ]; then
    echo "It's down! Try to restart."
    service network-manager restart
    fi
    sleep 5s
    done

    Maybe you need to adjust the "unknown" to your system language settings.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •