Results 1 to 10 of 10

Thread: Pages not loading in firefox after a minute of use

  1. #1
    Junior Member
    Join Date
    Jun 2017
    Posts
    5

    Pages not loading in firefox after a minute of use

    I am having issues with internet on my kali linux. I have downloaded the latest 64bit kali from kali website. i have live booted it from a usb pendrive everything works fine except for the internet. when i start kali, my wifi gets connected i am able to use the internet for a few minutes usually 2, and then pages stop loading although it shows the wifi is connected but pages dont load and then i have to turn on the airplane mode and of again and when it reconnects to wifi works for few minutes and then stop loading pages again.It shows server not found but all my other devices on the network works fine.The wifi works with windows fine it has this issue just with the kali linux. Please someone help me out this its quiet frustrating.

    my system configuration:

    Lenovo IdeaPad 310-15IKB

    ProcessorIntel Core i5-7200U 2.5 GHz

    Graphics adapter: Intel HD Graphics 620/geforce 920m

    Mainboard: Intel Kaby Lake-U Premium PCH

    Connections: 2 USB 2.0, 1 USB 3.0 / 3.1 Gen1, 1 VGA, 1 HDMI, 1 Kensington Lock, Audio Connections: 3.5 mm audio jack, Card Reader: 4-in-1 SD cardreader

    Bluetooth: Realtek Bluetooth Adapter

    WiFi: Realtek 8821AE Wireless LAN 802.11ac PCI-E NIC

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    600
    Have you ruled out problems with your ISP, and wireless router?

    Anything odd in the output of dmesg, or in /var/log? Can you curl or wget webpages ok?

  3. #3
    Junior Member
    Join Date
    Jun 2017
    Posts
    5
    Yes there is no problem with my isp and router because i can use it on other devices. just with kali i cam use it for 2 minutes and then the pages stop loading. if I turn off wifi and then turn it on again the wifi works for few minutes and then the problem shows up again

  4. #4
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    600
    Ok, that eliminates some obvious stuff. What happens when you try to curl or wget webpages? You might need to wget a download of Kali for a valid test, if your connection goes down after a couple minutes.

    Any errors in the output of dmesg or /var/log?

  5. #5
    Junior Member
    Join Date
    Jun 2017
    Posts
    5
    same thing with wget i tried downloading a webpage. It downloaded the first time I tried but om second attempt it showed Unable to resolve host address

  6. #6
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    600
    Hmm, how does your connection work via ethernet from this machine? Have you ruled out any RF interference nearby, which could be messing with your wifi signal?

  7. #7
    Junior Member
    Join Date
    Jun 2017
    Posts
    5
    Internet works perfectly fine on ethernet. i dont think there is any rf interference because it happens even if i sit close to the wifi router. I tried installing mint too same thing happens
    Last edited by Drazzer; 2017-06-20 at 06:46 AM.

  8. #8
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    600
    Must be something with your laptop's wifi. Do you have another wifi card you can try?

    FYI, my best wifi connection is when I'm 3 - 5 meters from the access point...could just be my gear, though.

  9. #9
    Junior Member
    Join Date
    Jun 2017
    Posts
    5
    here's something i discovered. i tried using aircrack it works fine just browsing the internet is causing problems

  10. #10
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    600
    Hmm, that's odd. It must be the wifi card, but if that's the case, aircrack usually won't work either.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •