Results 1 to 9 of 9

Thread: ifconfig wlan0 up “SIOCSIFFLAGS: Operation not possible due to RF-kill”

  1. #1
    Join Date
    2013-Mar
    Posts
    23

    ifconfig wlan0 up “SIOCSIFFLAGS: Operation not possible due to RF-kill”

    Hello everyone,

    I can't get my wifi working.

    I have the exact same problem as this person

    http://thelinuxexperiment.com/guinea...-with-rf-kill/

    Also it set to "flight mode" and even though I turn it off it doesn't change.

    when I type ifconfig wlan0 up I get the message “SIOCSIFFLAGS: Operation not possible due to RF-kill”

    does anyone have any idea what I can do about this?

    thanks in advance!

    Best Wishes
    Kraako

  2. #2
    Join Date
    2013-Mar
    Posts
    23
    Problem Solved, I removed the battery from my laptop and put it back in and then it worked

  3. #3
    Join Date
    2013-Mar
    Posts
    7
    If you are using the rtl8187 driver try the folloing:

    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    You can also copy the following scrip, make it execuable and run it as need it, just give a name easy for you to remember
    then run in the teminal /root/[name of scrip]

    #!/bin/bash
    echo Remove RTL8187 Module
    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    echo Add RTL8187 Module
    modprobe rtl8187
    rfkill unblock all
    echo Bring wlan0 Up
    ifconfig wlan0 up
    That should do it

  4. #4
    Join Date
    2013-Mar
    Posts
    23
    Okay thanks I will try that out

  5. #5
    You are an absolute Genius !,, not 1 person on any board solved this !,, and Kali doesn't have rfkill ,, YOUR SOLUTION WORKED 100% !!!! and was so simple, ,, lol,, take batery out,, man ow man,, after days of working on this.

  6. #6
    Join Date
    2013-Apr
    Posts
    1
    Not sure if it'll work for u, but i fixed the prob with this script:

    #!/usr/bin/python
    # replacement for rfkill util, which is missing in kali
    # By: Geist

    from sys import argv

    if(argv[1] == "unblock"):
    x = open("/sys/class/rfkill/rfkill%s/soft" % argv[2], "w")
    x.seek(0)
    x.write('0')
    elif(argv[1] == "block"):
    x = open("/sys/class/rfkill/rfkill%s/soft" % argv[2], "w")
    x.seek(0)
    x.write('1')


    print("interface %s %sed" % (argv[2], argv[1]))

    ---

    as you can plainly see, it's in python. Probably not as full featured as the real rfkill, but it does the job.

  7. #7
    Join Date
    2013-Jul
    Posts
    8
    I have the same probllem. I have rtl8192ce. rfkill says I have a hard block. My wifi button if it ever worked is not responsive. Nothing notable in dmesg. Tried all button combos I can think of. My media keys which are not wifi related no longer stay on when i hit them, god knows what they origionally did. Trying to locate the block via software but there are too many nails

  8. #8
    Join Date
    2013-Aug
    Posts
    6
    APPLICATIONS MENU > SYSTEM TOOLS > PREFERENCES > SYSTEM SETTINGS

    open NETWORKS

    Now, toggle the AIRPLANE mode off and while it is still open (leave it alone) press your standby/power button. Let the system go into standby. Next resume the system and toggle your wifi button.

    Worked for me.

  9. #9
    Join Date
    2013-Aug
    Posts
    1

    thanks a lot

    Quote Originally Posted by Cod View Post
    APPLICATIONS MENU > SYSTEM TOOLS > PREFERENCES > SYSTEM SETTINGS

    open NETWORKS

    Now, toggle the AIRPLANE mode off and while it is still open (leave it alone) press your standby/power button. Let the system go into standby. Next resume the system and toggle your wifi button.

    Worked for me.
    you are a genius m8 ! worked for me

Similar Threads

  1. Replies: 1
    Last Post: 2017-01-06, 19:20
  2. Replies: 10
    Last Post: 2014-04-24, 10:58
  3. ifconfig shows wlan0 but airmon-ng won't start it
    By rpilover in forum General Archive
    Replies: 5
    Last Post: 2014-01-24, 02:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •