Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Raspberry 3 + Latest Kali - Airodump-ng issues

  1. #1
    Junior Member
    Join Date
    Jun 2017
    Posts
    2

    Question Raspberry 3 + Latest Kali - Airodump-ng issues

    Hello guys hope you're doing well

    I have a issue with Raspberry Pi 3 + latest Kali linux version while using airodump-ng.
    Currently I have a USB dongle model Ralink Technology, Corp. RT2870/RT3070 attached in.

    Everything works great, monitor mode, I can also list all networks around me but using airodump-ng wlan1mon all wireless clients are set as "(not associated)", even if they are in fact connected.
    I tried to make the same case using Ubuntu, but no problems happened there using the same USB wifi card, so using Ubunutu, I can see all routers / access points and all associated clients with their stations

    I've already tried to dist-upgrade, update, fresh reinstall, always get the same issue.
    Maybe is it something related to the driver, or a bug that should be filled to Raspberry pi log?

    For the record:
    - wpa_applicant / dhclient / NetworkManager were all "killed"
    - wlan0 (built-in Broadcom 43430 wifi) was turned "down" to avoid conflicts
    - rebooted / reinstalled / many times
    - no significant log / syslog / error_log to look into, everthing seems to be working as it should..
    - I can inject "deauth" over wifi and put disconnect currently connected wifi devices

    You can see my output here
    https://snag.gy/mitNbu.jpg


    Do you guys know a fix for this issue?
    Using Ubuntu it's fine, but i'd like to setup this tool on my RPI and make easier to transport in my car to grab handshakes when necessary

    Thanks

  2. #2
    Junior Member
    Join Date
    Jun 2017
    Location
    Virgo Supercluster, Hurtling though space next to a G2 type star.
    Posts
    20
    Edit: I see it doesn't help.
    Last edited by TechMonster; 2017-09-30 at 11:02 PM.

  3. #3
    Junior Member
    Join Date
    Jun 2017
    Posts
    2
    Quote Originally Posted by TechMonster View Post
    Instead of using "airmon-ng start wlan1" to put it in monitor mode can you try "ifconfig wlan1 down && iwconfig wlan1 mode monitor && ifconfig wlan1 up"? To reverse just repeat the same command, changing "mode monitor" to "mode managed".
    Hello

    It doesn't fix the issue, the same thing happens
    I think it's something related to the driver used for RT2870/RT3070 on ARM architecture....no idea

  4. #4
    Junior Member
    Join Date
    Jun 2017
    Location
    Virgo Supercluster, Hurtling though space next to a G2 type star.
    Posts
    20
    Ok, I see its highly unusual. Have you tried the -a flag on airodump-ng? Probably not going to make a difference?
    Last edited by TechMonster; 2017-09-30 at 11:02 PM.

  5. #5
    Junior Member
    Join Date
    Sep 2017
    Posts
    1
    I have the same issue, any solution?

  6. #6
    Junior Member
    Join Date
    Sep 2017
    Posts
    5
    Been having the same damn frustrating. Only tool doing anything weird is Fluxion tho. Everything else is fine. Worked great last night then this morning airodump-ng errors all over the place.

  7. #7
    Junior Member
    Join Date
    Sep 2017
    Posts
    5
    Okay what I did was delete, git clone fresh install.

    apt-get install fluxion

    Cd fluxion

    ./fluxion.sh

    Been working fine all night now. Also after I deleted I updated and upgraded my Kali before reinstalling.
    I once knew a savant, never cared to do anything with his god given talent. God how I begged to come along for the grand journey but as I know all too well the line between sanity and madness is as thin as genius and that horrifying abyss. Stay sane, use your gifts. After all it's the age of the nerds, I've broken so many a gorgeous heart. Enjoy our glory days boys.

  8. #8
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    Hi e0xbr,

    As a workaround, you can install the nexmon drivers and use wlan0.
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  9. #9
    Member
    Join Date
    Jan 2015
    Posts
    30
    Quote Originally Posted by re4son View Post
    Hi e0xbr,

    As a workaround, you can install the nexmon drivers and use wlan0.
    Sorry if it is an offtopic, but could not find any similar threads:

    re4son, can you please help me with an issue:

    I made a fresh install of the latest version of Kali with your kernel.
    When starting reaver, theres no pixiewps implementation in reaver.
    How can I install reaver with pixiwps insed it.
    Is it your specific buld option, or it is so in the new kali version there's only a separate reaver / pixie choice.

  10. #10
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    121
    Odd, what's the version number of your reaver?
    I've got v1.6.2 with both the -K and -Z parameters and I did a normal "apt install reaver"
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •