Results 1 to 18 of 18

Thread: Raspberry 3 + Latest Kali - Airodump-ng issues

  1. #1
    Join Date
    2017-Jun
    Posts
    2

    Question Raspberry 3 + Latest Kali - Airodump-ng issues

    Hello guys hope you're doing well

    I have a issue with Raspberry Pi 3 + latest Kali linux version while using airodump-ng.
    Currently I have a USB dongle model Ralink Technology, Corp. RT2870/RT3070 attached in.

    Everything works great, monitor mode, I can also list all networks around me but using airodump-ng wlan1mon all wireless clients are set as "(not associated)", even if they are in fact connected.
    I tried to make the same case using Ubuntu, but no problems happened there using the same USB wifi card, so using Ubunutu, I can see all routers / access points and all associated clients with their stations

    I've already tried to dist-upgrade, update, fresh reinstall, always get the same issue.
    Maybe is it something related to the driver, or a bug that should be filled to Raspberry pi log?

    For the record:
    - wpa_applicant / dhclient / NetworkManager were all "killed"
    - wlan0 (built-in Broadcom 43430 wifi) was turned "down" to avoid conflicts
    - rebooted / reinstalled / many times
    - no significant log / syslog / error_log to look into, everthing seems to be working as it should..
    - I can inject "deauth" over wifi and put disconnect currently connected wifi devices

    You can see my output here
    https://snag.gy/mitNbu.jpg


    Do you guys know a fix for this issue?
    Using Ubuntu it's fine, but i'd like to setup this tool on my RPI and make easier to transport in my car to grab handshakes when necessary

    Thanks

  2. #2
    Join Date
    2017-Jun
    Location
    Somewhere in UK
    Posts
    20
    Edit: I see it doesn't help.
    Last edited by TechMonster; 2017-09-30 at 23:02.

  3. #3
    Join Date
    2017-Jun
    Posts
    2
    Quote Originally Posted by TechMonster View Post
    Instead of using "airmon-ng start wlan1" to put it in monitor mode can you try "ifconfig wlan1 down && iwconfig wlan1 mode monitor && ifconfig wlan1 up"? To reverse just repeat the same command, changing "mode monitor" to "mode managed".
    Hello

    It doesn't fix the issue, the same thing happens
    I think it's something related to the driver used for RT2870/RT3070 on ARM architecture....no idea

  4. #4
    Join Date
    2017-Jun
    Location
    Somewhere in UK
    Posts
    20
    Edit: Won't help, what I was suggesting.
    Last edited by TechMonster; 2017-10-28 at 21:34.

  5. #5
    Join Date
    2017-Sep
    Posts
    1
    I have the same issue, any solution?

  6. #6
    Join Date
    2017-Sep
    Posts
    5
    Been having the same **** frustrating. Only tool doing anything weird is Fluxion tho. Everything else is fine. Worked great last night then this morning airodump-ng errors all over the place.

  7. #7
    Join Date
    2017-Sep
    Posts
    5
    Okay what I did was delete, git clone fresh install.

    apt-get install fluxion

    Cd fluxion

    ./fluxion.sh

    Been working fine all night now. Also after I deleted I updated and upgraded my Kali before reinstalling.
    I once knew a savant, never cared to do anything with his god given talent. God how I begged to come along for the grand journey but as I know all too well the line between sanity and madness is as thin as genius and that horrifying abyss. Stay sane, use your gifts. After all it's the age of the nerds, I've broken so many a gorgeous heart. Enjoy our glory days boys.

  8. #8
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    182
    Hi e0xbr,

    As a workaround, you can install the nexmon drivers and use wlan0.
    ----------------------------------------
    https://re4son-kernel.com
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":
    https://re4son.com/kali-pi

    Now with mana-toolkit and more goodies!

  9. #9
    Join Date
    2015-Jan
    Posts
    30
    Quote Originally Posted by re4son View Post
    Hi e0xbr,

    As a workaround, you can install the nexmon drivers and use wlan0.
    Sorry if it is an offtopic, but could not find any similar threads:

    re4son, can you please help me with an issue:

    I made a fresh install of the latest version of Kali with your kernel.
    When starting reaver, theres no pixiewps implementation in reaver.
    How can I install reaver with pixiwps insed it.
    Is it your specific buld option, or it is so in the new kali version there's only a separate reaver / pixie choice.

  10. #10
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    182
    Odd, what's the version number of your reaver?
    I've got v1.6.2 with both the -K and -Z parameters and I did a normal "apt install reaver"
    ----------------------------------------
    https://re4son-kernel.com
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":
    https://re4son.com/kali-pi

    Now with mana-toolkit and more goodies!

  11. #11
    Join Date
    2015-Jan
    Posts
    30
    Mine is version 1.6.1-0kali1?
    Installed it with apt-get install.

    even wifite is not working properly, giving some error
    Last edited by mikrostart; 2017-09-29 at 20:13.

  12. #12
    Join Date
    2017-Jun
    Location
    Somewhere in UK
    Posts
    20
    Edit: I'm quite sure you can't install fluxion from apt. You can always clone from here. https://github.com/FluxionNetwork/fluxion
    Last edited by TechMonster; 2017-10-28 at 21:40.
    https://github.com/Sh3llcod3/Airscript-ng

  13. #13
    Join Date
    2017-Oct
    Posts
    1
    Hey there, are you sure that you used apt-get install fluxion ? What is your source.list.
    I suppose its not available to install through apt repostiory

    Regards

  14. #14
    Join Date
    2017-Oct
    Posts
    2
    I too am having this issue. Ap clients do not show up, I can deauth devices but cannot capture a handshake. I'm using the panda pau09 which is also Realtek chipset. I've tried installing parrotsec os to see if it was an issue with the kali arm image but still have the same problem.

    Sounds like it could be a Realtek arm driver issue. I'll try installing the driver from the included cd and report back results.

  15. #15
    Join Date
    2017-Oct
    Posts
    2
    update:
    Updated to re4sons latest kernel and handshakes are now being captured

  16. #16
    Join Date
    2017-Sep
    Posts
    22

    Lightbulb

    Quote Originally Posted by e0xbr View Post
    I have a issue with Raspberry Pi 3 + latest Kali linux version while using airodump-ng.
    Currently I have a USB dongle model Ralink Technology, Corp. RT2870/RT3070 attached in.

    Everything works great, monitor mode, I can also list all networks around me but using airodump-ng wlan1mon all wireless clients are set as "(not associated)", even if they are in fact connected.
    Same problem with a Pi (b) and RT2870/RT3070 USB dongle.

    I used the same dongle in a machine with the latest AMD64 Kali and it worked fine.

    I setup a test to confirm the problem.

    1. I set up an AP and used an Android client to connect to the AP and then to disconnect and connect to another AP, and then back and forth, so I am repeatedly sending the handshake
    2. In the AMD64 machine the client is correctly associated with the AP and the handshake is captured.
    3. In the ARM machine the client is not associated with the AP and the handshake is not captured.
    4. In both machines a DEAUTH attack would cause the clients to disconnect and reconnect but only the AMD64 would capture packets containing the handshakes.

    Done hours of searching and others have confirmed the same problem, those who solved it did so by upgrading their Kernel.

    I am trying to upgrade my kernel on the Pi to a later version by cross-compiling on my AMD64 Kali and creating a new image.

    Problem I have is that the latest version is rpi-4.9 but the Kali Arm build scripts only have config files for up to version rpi-4.4.

    When I attempt to change the config files to install the rpi-4.9 kernel the build script prompts me for a thousand, I kid you not, bleeding [NEW] config options, it would have taken all day to answer the questions about every piece of hardware ever manufactured.

    Anyone know how to change the build scripts so it doesn't ask for this information ?
    Last edited by PandorasBox; 2017-10-20 at 15:36.

  17. #17
    Join Date
    2017-Sep
    Posts
    22
    OK I can confirm that with a clean Raspbian image which installs Linux 4.9.41 on the same Pi solved the problem

    I cant find anyway to upgrade the Kali Linux on the Pi to Linux 4.9 and the Raspbian image works and takes minutes to install.

    Solution to problem.

    Download image from here https://www.raspberrypi.org/downloads/raspbian/

    Copy image to Pi SD card and boot into X, open a terminal and;

    sudo apt-get install wifite
    sudo wifite

    I used Wifite to test airodump-ng as it is the quickest way to test whether Airodump-ng correctly associates clients with APs and captures handshakes

    The Pi is much much quicker with Raspbian Linux than Kali Linux and it only installs packages you need on the Pi.
    Would be nice to see a proper headless image for Kali for the Pi. Set up to probe for vulnerabilities and then pass any hashcat stuff to a powerful PC or the Amazon OpenCL cloud.

    I wouldn't mind helping to test images before they go live, I really like the default Kali desktop

    Going to use Kali on my main PC for solving hashes and Raspbian on the Pi to capture and inject packets. If I can find a way to make the Kali use the latest version of Linux instead of the rolling version then I will post how, I figure if I use the config files from Raspbian then it should work.
    Last edited by PandorasBox; 2017-10-21 at 07:41.

  18. #18
    Join Date
    2017-Sep
    Posts
    22
    OK I figured out how to do this in the absence of kali config file for the 4.9 kernel

    Download the latest Raspberry Linux 4.9 source code and headers from github.

    Download the Kali 4.9 wifi patch file from the Kali Arm Build scripts called kali-wifi-injection-4.9.patch

    Follow the instruction on the Raspberry site for patching your kernel and apply the patch.....you have to test it with the dry run option and adjust the levels it strips from the file location until it finds the patch. If you look at the patch itself the top line is where it expects to find the files it is going to patch.

    Follow the cross-compiling how to on the Raspberry site and compile the kernel and save the image to your SD card.

    If you want to Kalify the Linux then make the alterations listed in the rpi.sh file found in the custom Kali build scripts to the files on the SD card.

    When you boot for the first time, it takes a while, I thought it was a dud image at first, run raspi-config and enable ssh.

    I tested this with aircrack-ng airodump-ng aireplay-ng airmon-ng reaver and wifite.

    I recovered the WPA password and WPS pin from my test router.
    Last edited by PandorasBox; 2017-10-25 at 17:10.

Similar Threads

  1. Latest Kali dsniff issues - no packets in arpspoof
    By tbdev in forum General Archive
    Replies: 3
    Last Post: 2016-12-05, 02:46

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •