Page 2 of 2 FirstFirst 12
Results 51 to 56 of 56

Thread: How to install AWUS036ACH Drivers and getting it running?

  1. #51
    Join Date
    2018-Feb
    Posts
    1
    Hi All,

    I'm new to the forum (only just registered!), not so new to Linux as it's part of my job, but new to Kali.
    I wanted to share a small victory in getting the drivers for Alfa AWUS036ACH installed - finally!

    I've installed 4.13.0 Kali on HP 440 g3, applied all the updates and couldn't see the card apart from looking in the dmesg.
    I've been getting error messages about missing directories in /lib/modules/4.13.0-kali1-amd64/ and after reviewing few forums, reinstalling Kali twice, I've finally found the correct way.

    After installing Kali, I've obviously had to run the below, otherwise it didn't want to update.

    apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6

    Then, it was a matter of apt-get update, followed with apt-get upgrade.
    After that was finished, I've started searching for the correct headers for my version of Kali - without any luck, unfortunately.

    I've found an article on a different forum, which pointed me to the right direction.
    First, I had to check for a newer version by running the below:

    apt-cache search linux-image
    apt-cache search linux-headers

    The results shown that there's 4.14.0-kali3-amd64 available and now it was a matter of installing the headers for it as well.

    apt install linux-image-4.14.0-kali3-amd64
    apt install linux-headers-4.14.0-kali3-amd64

    Then a quick, necessary reboot:

    shutdown -r now

    Finally, when the system booted uname -r shows that the upgrade was successful.
    One last attempt to get all the latest updates and it's time to install the driver. Fingers crossed.

    apt install realtek-rtl88xxau-dkms

    After the installation was finished, I've plugged in the USB WIFI, checked dmesg - it's present, and now it shows when running airmon-ng!
    Success It took a bit of google'ing to figure this one out and even though my friends at work also used to use Kali, they never had problems installing wifi cards.

    Either way, if someone will find this useful - happy days! : )

  2. #52
    Join Date
    2018-Feb
    Location
    USA
    Posts
    5
    If Iím not mistaken the WiFi USB adapter you speak of should work right out the box. I am using Kali rolling version 3 on MacBook Pro dual boot, with reFINd. The adapter worked for me right out the box before my keyboard and touchbar. I had to downgrade my kernel to get the keyboard drivers to work from the newist rolling version. However with the WiFi adapter, try to plug it in and do a fresh install see if Kali recognizes the device, which it should, and then it should configure it correctly. This is on dual boot. I would take the gentlemanís advise on the matter for virtual machines because majority if not all computers have started using usb 3.0 for a while now. Gotta love Kali though ! hope it helps !

  3. #53
    Join Date
    2018-Feb
    Posts
    1
    Just registered to say THANK YOU to everyone on this thread, especially re4son and Bu5h1d0. It's taken all of yesterday, most of last night and up to now but it appears to be working! Packet injection testing ok! I'm going for a lie down now ha.

    I encountered loads of problems, including headers not installing, packages not located, updating and upgrading etc. I work in computing (datacentres) so am quite computer literate but I'm completely new to Kali and Linux. As annoying as the last 24 hours have been, I feel like I've also learnt a fair bit too.

    Cheers everyone

    Charlie.

  4. #54
    Join Date
    2013-Aug
    Location
    St. Louis, MO
    Posts
    1
    Hello all; after messing with this, and reading much in these forums, I am still having an issue. First, the environment: Windows 10 laptop, Fall Creator's pkg, ASUS with Intel internal wifi. I have this Alfa 036ach usb card. I'm running Kali Linux rolling 3.xx in VMWorkstation, version 14.xxx. I have gone round and round, updating everything. Rest assured, A. Host OS is updated, B. Guest Kali OS has been apt-get updated, upgraded, and dist-upgraded. I'm on Kernel 4.14.0-kali3-amd64, with the apt install realtek-rtl88xxau-dkms done. My issue is something that I've not seen mentioned elsewhere:
    Card works fine in Win10 environment. When I try and get it to work in the Kali VM, it's problematic. Even with everything updated. One of the specific issues I'm having is that Kali works fine with the internal card. Soon as I try and click over to the ALFA card, I either have it show up twice and it says that there is a driver error, and it wont let me unconnect back to the host (it just gives me an error box), or if I do get some type of connectivity, I keep getting "Destination Host Unreachable" errors if I attempt to ping 8.8.8.8. I can ping internal network and gateway fine.

    I have uninstalled and re-installed the drivers, and the problem persists. I am making sure that I turn off "WiFi" in Win10 environment, and make sure WiFi3 is turned on. Win10 box is working fine.

    So, right now, my Win10 box is connected to Alfa card. I ensured I uninstalled the card from device manager, then plugged it back in. Re-installed drivers. All good; it's been working fine for 30 minutes. It's Wifi is off, but WiFi3 is on. I can see the MAC address of the device, so I know it's the one working. I fired up VM Workstation v 14.xx, and launch Kali. I can hear Windows ding as it disconnects the USB and attempts to connect it to the Kali VM. The icon at lower right corner of the VM environment is showing Realtek 8812AU wireless card. Kali launches...

    and when I attempt to ping 8.8.8.8, Destination Host Unreachable! What the heck is going on with this??? If I click on the Network Manager and pull down wifi settings, it's all blank. But I can ping internal ip's such as 127.0.0.1, my gateway, and other machines. But I can't ping outside network.

    Now, if I change USB slots, I can hear Windows disconnecting from OS and back into the VM, and now suddenly it sees the network. I can see the list of networks in Network Manager. But still get Destination Host Unreachable msgs!!!

  5. #55
    Join Date
    2018-Feb
    Posts
    1
    Hi
    I want Installed driver for USB Wireless Adapter in Kali linux with this command:
    apt install realtek-rtl8821au-dkms
    but I saw this message: E:unable to locate package realtek-rtl8821au-dkms
    and when I typed ifconfig in terminal , I didn't have a wifi in my option which I can use it.

  6. #56
    Join Date
    2018-Feb
    Posts
    1
    Hello Guys,

    Kali Linux (Just registered to this forum today but has been reading through the past week) newbie here but venturing to IT Security. My background is on networking and I am still having an issue getting the wifi adapter working on my machine even after following re4son and Bu5h1d0's posts.

    I am getting this on dmesg after connecting the adapter:

    [ 414.598663] usb 1-2: new high-speed USB device number 5 using xhci_hcd
    [ 414.989343] usb 1-2: New USB device found, idVendor=0bda, idProduct=8812
    [ 414.989350] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 414.989355] usb 1-2: Product: 802.11n NIC
    [ 414.989358] usb 1-2: Manufacturer: Realtek
    [ 414.989361] usb 1-2: SerialNumber: *removed*
    [ 415.192704] 8812au: loading out-of-tree module taints kernel.
    [ 415.195064] 8812au: Unknown symbol __x86_indirect_thunk_rcx (err 0)
    [ 4286.162920] 8812au: Unknown symbol __x86_indirect_thunk_rcx (err 0)
    [ 4286.163030] 8812au: Unknown symbol __x86_indirect_thunk_rdx (err 0)
    [ 4286.163097] 8812au: Unknown symbol __x86_indirect_thunk_r13 (err 0)
    [ 4286.163103] 8812au: Unknown symbol __x86_indirect_thunk_r12 (err 0)
    [ 4286.163113] 8812au: Unknown symbol __x86_indirect_thunk_rax (err 0)
    [ 4286.163167] 8812au: Unknown symbol __x86_indirect_thunk_r8 (err 0)
    [ 4286.213568] 8812au: Unknown symbol __x86_indirect_thunk_rcx (err 0)
    [ 4286.213665] 8812au: Unknown symbol __x86_indirect_thunk_rdx (err 0)
    [ 4286.213753] 8812au: Unknown symbol __x86_indirect_thunk_r13 (err 0)
    [ 4286.213762] 8812au: Unknown symbol __x86_indirect_thunk_r12 (err 0)
    [ 4286.213776] 8812au: Unknown symbol __x86_indirect_thunk_rax (err 0)
    [ 4286.213853] 8812au: Unknown symbol __x86_indirect_thunk_r8 (err 0)



    I can see the adapter on lsusb but not in ifconfig.

    root@****:~# uname -r
    4.14.0-kali3-amd64

    I am also not seeing any errors on modinfo 8812au

    I am running Kali Linux 2018.1 on a VMWare workstation (for now) on a Win7 machine. Any help would be great!
    Last edited by harv3y; 1 Hour Ago at 01:45. Reason: adding details

Similar Threads

  1. New Alfa awus036ach help
    By fatfarm5 in forum Kali Linux TroubleShooting
    Replies: 47
    Last Post: 2017-12-14, 10:47
  2. What tablet is capable of running a full Kali install?
    By nemes in forum General Archive
    Replies: 7
    Last Post: 2017-06-27, 11:06
  3. New install running slow
    By smorris in forum General Archive
    Replies: 0
    Last Post: 2017-03-07, 06:13
  4. Replies: 3
    Last Post: 2014-01-09, 14:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •