Results 1 to 4 of 4

Thread: Unable to get sound working on pi3 Model B Kali Linux

  1. #1
    Join Date
    2017-Jul
    Posts
    1

    Unable to get sound working on pi3 Model B Kali Linux

    Has any of you guys facing this issue , I'm unable to get sound on raspberry pi 3 model B running Kali linux :

    Kali Linux 2017.1
    4.4.5
    Installed alsa-utils
    sudo modprobe snd-bcm2835

    ran> systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    -rebooted

    systemctl --user status pulseaudio (running)
    amixer cset numid=3 2

    When I run speaker-test , I'm able to see sound bar responding but still no sound .(The volume is not muted neither in OS nor in the HDMI device ).



    Any hint on what the issue is ?

  2. #2
    Join Date
    2013-Oct
    Location
    SoCal
    Posts
    22
    Quote Originally Posted by thepac View Post
    Has any of you guys facing this issue , I'm unable to get sound on raspberry pi 3 model B running Kali linux :

    Kali Linux 2017.1
    4.4.5
    Installed alsa-utils
    sudo modprobe snd-bcm2835

    ran> systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    -rebooted

    systemctl --user status pulseaudio (running)
    amixer cset numid=3 2

    When I run speaker-test , I'm able to see sound bar responding but still no sound .(The volume is not muted neither in OS nor in the HDMI device ).



    Any hint on what the issue is ?
    I have the same issue, but it seems like you've had more success than me.

    Did you create a config.txt file yet?

  3. #3
    Join Date
    2013-Oct
    Location
    SoCal
    Posts
    22

    Update

    Quote Originally Posted by thepac View Post
    Has any of you guys facing this issue , I'm unable to get sound on raspberry pi 3 model B running Kali linux :

    Kali Linux 2017.1
    4.4.5
    Installed alsa-utils
    sudo modprobe snd-bcm2835

    ran> systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    -rebooted

    systemctl --user status pulseaudio (running)
    amixer cset numid=3 2

    When I run speaker-test , I'm able to see sound bar responding but still no sound .(The volume is not muted neither in OS nor in the HDMI device ).



    Any hint on what the issue is ?
    I'm to this point now. Using the pulseaudio volume control from the command line, I can see the status and testing with YouTube it shows the volume status changing. Unfortunately, I get no audio output...

    I'm really confused what the problem could be.

    I found where it recommends installing pulseaudio-alsa package, but when I try. I can't locate it... Supposedly it fixes conflicts with ALSA and forces the use of pulseaudio.
    Last edited by sdse; 2017-08-08 at 05:37.

  4. #4
    Join Date
    2013-Oct
    Location
    SoCal
    Posts
    22
    I have good news. I have found the solution to the HDMI audio output problem.

    Please read here >> http://sdatic.com/?p=60 for more information.

    If you still have issues, please contact me because I have my audio working perfect via HDMI.

Similar Threads

  1. Kali Linux and Raspberry 3 Model B do not work together
    By l3avemehere in forum ARM Archive
    Replies: 0
    Last Post: 2017-02-20, 08:16
  2. Replies: 2
    Last Post: 2016-09-13, 11:57
  3. Sound Not working. Kali- Dell Inspiron N7110
    By black in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-04-18, 16:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •