Results 1 to 4 of 4

Thread: mt7610u_wifi_sta_v3002_dpo_20130916 Driver won't install

  1. #1
    Junior Member
    Join Date
    Jul 2017
    Posts
    2

    mt7610u_wifi_sta_v3002_dpo_20130916 Driver won't install

    Hello Guys, i need some help with my Kali Linux Debian 64x 4.9.0 VMWare

    I am trying to install that driver but every time i type in make or sudo make i get this Error:
    Screenshot (6).jpg

    uname -a shows this: "Linux kali 4.9.0-kali4-amd64 #1 SMP Debian 4.9.30-2kali1 (2017-06-22) x86_64 GNU/Linux"
    leafpad source.list shows this: "# deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160830-11:29]/ kali-rolling contrib main non-free

    #deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160830-11:29]/ kali-rolling contrib main non-free

    deb http://http.kali.org/kali kali-rolling main non-free contrib
    deb-src http://http.kali.org/kali kali-rolling main non-free contrib"

    When i plug in my Archer T2UH i get bluetooth but its alway off
    i had also many problems with my Kernel Header but i finaly updated it... atleast thats what i think

    if you need any more information please Ask i will reply as fast as i can

    EDIT: I installed the driver and everything looks good but my usb adapter is shown as ra0 and no wifi is showing up what should i do?
    Last edited by Dimitrios13; 2017-07-19 at 03:47 AM.

  2. #2
    Member
    Join Date
    Dec 2016
    Posts
    75
    Probably because it's something for 2013 and we're in 2017. Lots of things have changed in the kernel in 4 years.

    Just FYI, your screenshot is a tiny image, impossible to see anything. And posting the whole compile log when saying it's not working as there can be a bunch of different causes. You're like asking a plumber to fix your broken pipe by asking "Could you fix plumbing?", he'll need more details.

  3. #3
    Junior Member
    Join Date
    Jul 2017
    Posts
    2
    I updated everything but after i press on the wifi icon(it sais wifi not connectec) it searches for routers but no router shows up. I do it like that: First i type in ifconfig ra0 up and sometimes i get error and then i do (after i did cd /etc/NetworkManager/) service network-manager reset and then i do again the ifconfig ra0 up. Sometimes it workes with the second try but thats rare. I do it like 20 Times and if ifconfig ra0 up worked wifi sometimes still doesn't pop up then i unplug usb adapter and plug it back. Here is the full tutorial: https://medium.com/@honsontran/insta...x-4fa2db52cd69

    and one last important thing: When use my TP Link Archer T2UH on Windows it blinks but after i switch it to VMWare it stops blinking and there is just a green dot. After i do ifconfig ra0 up the green dot goes away

  4. #4
    Junior Member
    Join Date
    Jul 2017
    Posts
    1
    So is your TP Link T2UH working on your machine?
    I'm running the same kernel as you, and installed the drivers from mt7610u_wifi_sta_v3002_dpo_20130916-master. I can run ifconfig -a and see ra0 interface, but comes up with no MAC ADDRESS....

    ra0: flags=4098<BROADCAST,MULTICAST> mtu 1500
    ether 00:00:00:00:00:00 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    I suspect this has something to do with the drivers. It seemed like you got yours working?
    If I run an ifconfig ra0 up, the command just hangs (forever).

    lsusb displays my attached device
    root@kali:~/t2uh# lsusb
    Bus 001 Device 003: ID 148f:761a Ralink Technology, Corp.


    Got anything else I can test or try?

    Anyone else got any ideas? I've been through countless forums and google searches to dead ends.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •