Results 1 to 15 of 15

Thread: Airmon-ng Cannot Put wlan0 into Monitor Mode

  1. #1
    Join Date
    2017-Jul
    Posts
    8

    Exclamation Airmon-ng Cannot Put wlan0 into Monitor Mode

    I am using an external USB wireless adapter TP-LINK TL-WN722N V2 and I have just spent the last 4 hours installing the driver for it to work. My issue now is I cannot set it into monitor mode with airmon-ng start wlan0. I have run airmon-ng check kill and it still produces the following output:

    Code:
    root@kali:~# airmon-ng check kill; airmon-ng start wlan0
    
    Killing these processes:
    
      PID Name
    16277 wpa_supplicant
    
    
    
    PHY	Interface	Driver		Chipset
    
    phy7	wlan0		??????		 
    cat: /sys/class/ieee80211/phy7/device/net/wlan0mon/type: No such file or directory
    
    Newly created monitor mode interface wlan0mon is *NOT* in monitor mode.
    Removing non-monitor wlan0mon interface...
    
    WARNING: unable to start monitor mode, please run "airmon-ng check kill"
    As you can see, the Driver and Chipset are not detected in the output from airmon-ng.




    Output of iwconfig:
    Code:
    wlan1     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
              Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    Output of ifconfig:
    Code:
    eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether b8:88:e3:e1:30:4b  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1  (Local Loopback)
            RX packets 10235  bytes 822767 (803.4 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 10235  bytes 822767 (803.4 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether d4:6e:0e:0f:83:7b  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 4407499 (4.2 MiB)
            RX errors 0  dropped 64  overruns 0  frame 0
            TX packets 0  bytes 3506227 (3.3 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlan1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether ce:5b:ae:0b:86:a0  txqueuelen 1000  (Ethernet)
            RX packets 488  bytes 116148 (113.4 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 626  bytes 353786 (345.4 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    Note, the external wifi adapter is wlan0, wlan1 is inbuilt into my laptop (but not usable for hacking).

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    773
    Try touch /sys/class/ieee80211/phy7/device/net/wlan0mon/type to create the missing file, reboot, and see if that works.

    Not had this problem myself, but creating a missing file manually is my go-to troubleshooting technique

    Might also be necessary to disable your wlan1 interface, have had problems with incompatible in-built device conflicts.

  3. #3
    Join Date
    2017-Jul
    Posts
    8
    I actually already tried that, but I can't do anything in the /phyX/device/net directory.. all my commands result in Operation not permitted.

    I tried disabling my secondary wlan interface then trying and it didn't change anything.

    Also, I turned monitor mode on for my secondary wlan interface and look inside the /phyX/device/net directory to see what happens before and after. It starts off as having a directory called wlan1, then after turning monitor mode, the contents become a single directory called wlan1mon.

  4. #4
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    773
    That's odd, I would think as root, you could do anything in any directory.

    Makes sense, since airmon-ng places the device in monitor mode. I'm stumped...suggest you check forum.aircrack-ng.org

  5. #5
    Join Date
    2017-Jul
    Posts
    8
    Idk, I've tried so much. I'm just going to give up and try Wifislax (os) a go to see if I have any luck with that. It's easier to setup **** but natively an English OS.

    I'll post here if I have any success with Wifislax and my TP-LINK TL-WN722N V2 external wireless adapter.
    Last edited by g0tmi1k; 2018-02-13 at 13:19. Reason: Foul language

  6. #6
    Join Date
    2017-Jul
    Posts
    8
    I had no success with Wifislax (some annoying error wouldn't even let me boot it).

    I just want to say that I am able to put my external network card into monitor mode with
    Code:
    ifconfig wan1 down; iwconfig wlan1 mode monitor; ifconfig wlan1 up
    (but not with airmon-ng start wlan1) but I still have some issues with it.
    Some automatic scripts like fluxion and wifite don't allow me to use the network card and reaver is unable to receive a beacon when trying to hack a ap.

  7. #7
    Join Date
    2013-Jul
    Posts
    819
    To Acidic9

    You might try using iw instead of airmon-ng

    iw wlan0 interface add mon0 type monitor

    Read thru

    https://forums.kali.org/showthread.p...tiple+monitors

    You might also try

    iw wlan0 interface add wlan0mon type monitor

    Then type airmon-ng [Enter] and see if airmon-ng accepts it.

    or use an older version of airmon-ng. We can post for download if you need it or download our latest varmacscan we put an older version in the script as an option during setup.

    Reference airmon-ng check kill

    This is just a series of service commands killing Network Manager and wpa supplicant.

    Musket Teams
    Last edited by mmusket33; 2017-07-28 at 16:45.

  8. #8
    Join Date
    2017-Jul
    Posts
    8
    You might try using iw instead of airmon-ng

    iw wlan0 interface add mon0 type monitor
    I attempted the command above and received no output, but I can confirm mon0 was added by typing iwconfig:

    Code:
    root@kali:~# iw wlan0 interface add mon0 type monitor
    root@kali:~# iwconfig
    wlan1     IEEE 802.11  ESSID:"fmt.Println("Internet")"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: E0:46:9A:8A:78:4D   
              Bit Rate=54 Mb/s   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=70/70  Signal level=-39 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:9  Invalid misc:5   Missed beacon:0
    
    mon0      IEEE 802.11  Mode:Monitor  Tx-Power=12 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              
    wlan0     IEEE 802.11bg  ESSID:"fmt.Println("Internet")"  Nickname:"<WIFI@REALTEK>"
              Mode:Managed  Frequency:2.412 GHz  Access Point: E0:46:9A:8A:78:4D   
              Bit Rate:54 Mb/s   Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:****-****-****-****-****-****-****-****   Security mode:open
              Power Management:off
              Link Quality=100/100  Signal level=74/100  Noise level=0/100
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    I have my mon0 ready (so it seems) and I attempt to use airodump-ng to monitor the networks around me.

    Code:
    root@kali:~# airmon-ng mon0
    
     CH  4 ][ Elapsed: 6 s ][ 2017-07-29 12:20                                         
                                                                                                                                                   
     BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID
                                                                                                                                                   
                                                                                                                                                   
     BSSID              STATION            PWR   Rate    Lost    Frames  Probe
    But it doesn't detect any networks around me.


    You might also try

    iw wlan0 interface add wlan0mon type monitor

    Then type airmon-ng [Enter] and see if airmon-ng accepts it.
    I unplugged and plugged my external network adapter from my laptop and mon0 was gone so I was back to having only wlan0 (and wlan1 which is my in-built network adapter).
    I then ran
    Code:
    iw wlan0 interface add wlan0mon type monitor
    successfully but then after running airmon-ng I was left with the following output:

    Code:
    root@kali:~# iw wlan0 interface add wlan0mon type monitor
    root@kali:~# airmon-ng
    
    PHY	Interface	Driver		Chipset
    
    phy5	wlan0		??????		 
    
    ethtool failed...
    Only mac80211 devices on kernel 2.6.33 or higher are officially supported by airmon-ng.



    FYI, the output of uname -r is 4.9.0-kali4-amd64.

  9. #9
    Join Date
    2017-Jul
    Posts
    1
    I had same problem.try this command
    iwconfig wlan1 mode monitor

  10. #10
    Join Date
    2017-Jul
    Posts
    8
    Quote Originally Posted by Pixy View Post
    I had same problem.try this command
    iwconfig wlan1 mode monitor
    Look at post #6

    Essentially, I am able to go into monitor mode, but it doesn't act as expected.

  11. #11
    Join Date
    2017-Aug
    Posts
    1
    Once I read somewhere that TP-LINK TL-WN722N V2 doesn't work with monitor mode, the problem is in the V2, that means it has a chipset that is not supported. Try to buy one that is V1 and will work fine!

    I don't know how to know if the device is V1 or V2 buy just looking at the box or something if you find that out please share!

  12. #12
    Join Date
    2017-Jul
    Posts
    2
    Check out this post. It is stating V2 of the TP-LINK TL-WN722N is not supported / not working:
    http://www.wirelesshack.org/best-kal...gles-2016.html

  13. #13
    Join Date
    2013-Jul
    Posts
    819
    This V1/V2 problem seems to have a solution

    Go to this link and read the last entries

    https://forums.kali.org/showthread.p...e-Problem-HELP!


    Musket Teams

  14. #14
    Join Date
    2017-Oct
    Posts
    4
    Quote Originally Posted by Tengoles View Post
    ... I don't know how to know if the device is V1 or V2...
    On the back of the device you should see a label with the TP-LINK logo. On that same label you will see to the bottom left S/N. moving to the right from there is a bar code with numbers under it (the serial numbers). At the end of those numbers you will see a "V" fallowed by number/s. For Example: [serial number] V1.1

    Can you type uname -a in terminal and post the output please.

  15. #15
    Join Date
    2017-Sep
    Location
    Developing, please wait...
    Posts
    6
    Quote Originally Posted by Acidic9 View Post
    Look at post #6

    Essentially, I am able to go into monitor mode, but it doesn't act as expected.
    It may be the chipset in your adapter. I have an Atheros model AWUS036NHA. Works with fluxion and reaver. No issues.

Similar Threads

  1. Can't monitor wlan0 via airmon-ng on Kali within VirtualBox
    By Mrokii in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2017-01-20, 16:23
  2. Wlan0 booting into monitor mode after 'apt-get dist-upgrade'
    By Macros1980 in forum General Archive
    Replies: 1
    Last Post: 2016-12-14, 11:29
  3. Replies: 8
    Last Post: 2015-12-16, 18:48
  4. Monitor Mode Wlan0
    By N4 Nethunter in forum NetHunter Suggestions
    Replies: 3
    Last Post: 2015-03-07, 11:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •