Results 1 to 2 of 2

Thread: Alfa AWUS036ACH (brand new) can only see 5 networks on Kali?

  1. #1
    Join Date
    2013-May
    Posts
    9

    Question Alfa AWUS036ACH (brand new) can only see 5 networks on Kali?

    Hey guys. I am trying to get my brand new Alfa AWUS036ACH to work. On Windows I can see 48 networks on the device. With 22 networks on my internal Intel 8260.

    First I installed the drivers that support injection with:

    Code:
    apt-get update
    apt install realtek-rtl88xxau-dkms
    Then I disabled my internal Wi-fi to prevent conflicts:

    Code:
    rfkill block 0  <-- (Where 0 is the internal Wi-fi device #)
    Next I kill any conflicting processes:

    Code:
    airmon-ng check kill
    Then I ran monitor mode on the Alfa AWUS036ACH device.
    The traditional method doesn't seem to work, but I found this method on a blog.

    Code:
    ip link set wlan1 down
    iwconfig wlan1 mode monitor
    ip link set wlan1 up
    Now let's actually start monitoring networks

    Code:
    airodump-ng wlan1
    The problem is that it shows there are only FIVE networks around me. As I said, in windows I can see FORTY EIGHT
    networks in my area with the Alfa device. With my inbuilt Intel 8260 I can see at least 22 of those. With both cards enabled
    in Kali I can only see these 5 that the Alfa shows (on both cards in network-manager)

    What am I doing wrong?

    Here's a readout of "iwconfig"

    Code:
    root@gitgud:~# iwconfig
    lo        no wireless extensions.
    
    wlan1     IEEE 802.11  Mode:Monitor  Frequency:2.422 GHz  Tx-Power=18 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=off   (disabled with rfkill in this readout)
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    (wlan0 is my Intel 8260 and wlan1 is my Alfa)

    Disconnecting the Alfa device causes the internal Intel 8260 to display all 22-ish networks again.

    Am I missing a driver or a step or something?

    Any help would be greatly appreciated!
    Last edited by Leijonasisu; 2017-08-01 at 17:23.

  2. #2
    Join Date
    2013-May
    Posts
    9
    Hi,

    Turns out it's a f__king problem with the USB 3 cable. Due to it using the old USB 3 interface (split Mini USB + USB3) the cable doesn't make proper connection with the USB 3 interface on the device. This is due to the cable weight and just garbage interface layout in general. i.e. The reason why we now have reversible USB 3 (the interface connectivity sucking @ss) is why my Alfa can only find 5 networks.

    Plugging an old mini USB 2 into the first part of the USB 3 interface on the Alfa instantly shows me a good 30+ networks in range. The downside of course is that I lose 1000mbps of throughput.. and I'm stuck at USB 2.0 speeds of about 250Mbps. I'm going to look for a way to run the Alfa with the garbage old USB 3 interface and somehow not have to deal with issues of the connection being flimsy. If anyone has any ideas that would be greatly appreciated!

Similar Threads

  1. Replies: 7
    Last Post: 2017-10-22, 22:38
  2. Alfa AWUS036ACH on kali 2017.1 monitor mode issue
    By superbosu in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2017-08-30, 03:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •