Results 1 to 4 of 4

Thread: No wireless extention wlan0 not showing

  1. #1
    Junior Member
    Join Date
    Aug 2017
    Posts
    2

    No wireless extention wlan0 not showing

    Hello, this is 3rd day and i have seen various forums troubleshooting usb wifi card problem. My kali linux in vmware was working fine until i fully upgrade it. After the upgradation i cannot see my wireless card. There is no wireless driver but the internet is working i dont know how. I have tried to install compact-wireless drivers for linux, My Edimax drivers but all just failed. Whenever i try to make install driver make error generated "/lib/modules/4.9.0-kali4-amd64/kernel/drivers/net': No such file or directory" . I don't why this is happening because i have install the linux~headers, kali-wireless, and done the apt intall update && upgrade && dist-upgrade .
    iwconfig shows = eht0- no wireless extensions.
    I am not able to isnstall the driver there is always make error that lib/driver/net there is no such directory. also tried apt-get install realtek-rtl88xxau-dkms but nothing works. Help
    uname -a
    Linux kali 4.9.0-kali4-amd64 #1 SMP Debian 4.9.30-2kali1 (2017-06-22) x86_64 GNU/Linux
    error.jpg

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    635
    If you took a snapshot before the upgrade, I'd roll back to that, then try the upgrade again. If all was well before the upgrade, it must be something there that trashed your wireless connectivity.

    Anything helpful in the output of dmesg or in /var/log?

  3. #3
    Member
    Join Date
    Dec 2016
    Posts
    76
    just FYI, upgrade is not a command and dist-upgrade is not a command. Both are parameters to apt-get. Another thing, dist-upgrade already does upgrade, so upgrade is pointless.

    The last error from make is useless, you need to post the FULL compilation log.

  4. #4
    Junior Member
    Join Date
    Aug 2017
    Posts
    2
    Quote Originally Posted by grid View Post
    If you took a snapshot before the upgrade, I'd roll back to that, then try the upgrade again. If all was well before the upgrade, it must be something there that trashed your wireless connectivity.

    Anything helpful in the output of dmesg or in /var/log?
    Sorry, I don't have a snapshot. Also, i want to tell that after the upgrade when i reboot my kali i got stuck in "initram boot error" which i troubleshoot.
    I found this -
    [ 2.642138] usb 1-1: New USB device found, idVendor=7392, idProduct=7811
    [ 2.642141] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 2.642143] usb 1-1: Product: 802.11n WLAN Adapter
    [ 2.642144] usb 1-1: Manufacturer: Realtek
    [ 2.642146] usb 1-1: SerialNumber: 00e04c000001
    [ 2.753787] usb 2-2: new full-speed USB device number 3 using uhci_hcd
    [ 2.765794] usb 1-2: new high-speed USB device number 3 using ehci-pci
    [ 2.898218] usb 2-2: New USB device found, idVendor=0e0f, idProduct=0002
    [ 2.898222] usb 2-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
    [ 2.898224] usb 2-2: Product: VMware Virtual USB Hub
    Also
    [ 149.831886] e1000: eth0 NIC Link is Down
    [ 153.862515] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
    Please tell me what should i do, as i i don't want to res-install.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •