Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: I do not have the sound after installing distribuition kali linux in Asus X58L

  1. #1
    Junior Member
    Join Date
    Aug 2017
    Posts
    6

    Question I do not have the sound after installing distribuition kali linux in Asus X58L

    Hi, I have this problem: I installed Kali Linux distribuition in HDD on this ASUS X58L laptop and when I'm in my user account, I no longer have the sound.
    Before I get into my user account I see the sound icon, but after I logged in the user account I no longer see the icon and if I'm on the internet I do not hear any sounds.

    Kali Linux is the only OS

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    654
    Try systemctl --user enable pulseaudio && systemctl --user start pulseaudio

  3. #3
    Junior Member
    Join Date
    Aug 2017
    Posts
    6
    Quote Originally Posted by grid View Post
    Try systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    Hi, sorry my bad english, I translate it with google.

    The GNU GRUB is 2.02 beta3-5

    IMG_2899.jpg

    I do not know if this is what you meant, I opened a "Terminal" window and I wrote "systemctl enable pulseaudio", so it says "failed to enable unit: pulseaudio.service file: no such file or directory"

    Schermata del 2017-08-10 17-12-09.jpg

    This below is what I see if within the audio settings

    Schermata del 2017-06-22 19-43-48.jpg

  4. #4
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    615
    Quote Originally Posted by Primula Rossa View Post
    Hi, sorry my bad english, I translate it with google.

    The GNU GRUB is 2.02 beta3-5

    IMG_2899.jpg

    I do not know if this is what you meant, I opened a "Terminal" window and I wrote "systemctl enable pulseaudio", so it says "failed to enable unit: pulseaudio.service file: no such file or directory"

    Schermata del 2017-08-10 17-12-09.jpg

    This below is what I see if within the audio settings

    Schermata del 2017-06-22 19-43-48.jpg
    --You typed it wrong. --Copy paste the command.

  5. #5
    Junior Member
    Join Date
    Aug 2017
    Posts
    6
    Quote Originally Posted by _defalt View Post
    --You typed it wrong. --Copy paste the command.
    But I have to type exactly so "systemctl --user enable pulseaudio"?

  6. #6
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    654
    Right, just copy/paste the entire command as-is...everything past the word "Try"

  7. #7
    Junior Member
    Join Date
    Aug 2017
    Posts
    6
    Thank you, following your advice, I resolved.
    Now I hear the sound. !!

    Schermata del 2017-08-11 23-39-48.jpg

  8. #8
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    654
    No problem, glad it worked

  9. #9
    Junior Member
    Join Date
    Aug 2017
    Posts
    6
    It might be interesting to deepen the subject.
    What it is and what it can do "systemctl"?
    What is "pulseaudio.service" and "pulseaudio.socket"?
    Last edited by Primula Rossa; 2017-08-17 at 04:15 PM.

  10. #10
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    654
    Best place I can direct you is the man pages for systemctl. In short, the systemctl command allows you to control systemd and the service manager.

    How deep is your Linux knowledge? Since Kali is based off Debian, you can also refer to Debian documentation if you need more info.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •