During booting the machine I hold alt down and selecting the kali installation (which mac lists as windows). I get to the grub and select an option and kali boots, but after running failing /scripts/local-blocking it tell me that the lvm-root cannot be found and exits to initramfs.

Original the installation failed at the "instaIl grub" point, and I managed first to get it to boot to grub's minibash and now to the initramfs.

I am in doubt about the Mac EFI partition and Kali's boot.
It seem to be correct that I mount the EFI partition to my boot. Is it correct or a source of my problems?
mount /dev/sda1 /boot
If I don't the grub-install fails. Mounting /dev/sda1 to /boot makes it possible to do grub-install, but that also only works if I add "--force"
grub-install --force /dev/sda
It also only works with the grub-pc installed. I tried and only failed with the grub-efi installed.

Before it asked for the luks password right after selecting the "windows" harddisk icon in the mac boot. It doesn't anymore (and I can't remember what I changed), but I get the same error says that the lvm-root could not be found, and drops me to the initiramfs.

I then decrypt the lvm and mount the two disks within the lvm (/ and swap) and exits.
Kali continues to boot and works fine.

But how do I get it to boot without dropping me to the initiramfs?
I guess that it is the decryption that is not working.

GRUB_PRELOAD_MODULES="lvm luks cryptodisk"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz cryptdevice=UUID=6f0b1fa1-c89d-4189-aca9-f7f318d9e4cb:ssd root=UUID=c1271072-41a9-4002-8a4d-8a0a085c9165 luks.uuid=llDjoa-dVFZ-342V-u8p4-kHIW-JycZ-CP2FX7"
sda4_crypt UUID=6f0b1fa1-c89d-4189-aca9-f7f318d9e4cb none luks
/dev/mapper/ssd-kali / errors=remount-ro 0 1 # not sure if this is correct

Once I am logged in i do/try
mount /dev/sda1 /boot
update-initramfs -k all -c
grub-install --force /dev/sda
I 'think' (changed and tried so much the last two days I can't remember) I even managed to get it to boot perfectly with 4.9 (not I am on 4.11), but of cause I "managed" to delete the grub config before backing it up.

Any help here???