I've been having a lot of trouble with my dual boot installation. Basically the problem is that when I boot all goes well until the login screen - at this point after I have entered details it just goes to a grey screen with no prompt or anything. I also can't access the terminal from here.

So far I have tried reinstalling the ISO, installing drivers (failed). I have also tried booting from the live USB and editing the files and installing from here. I can get into the recovery boot though but sometimes and more recently has been giving me a pcie bus error loop. I have also seen some errors during the boot about a flat table pointer error.


I assume it's because of my gpu - gtx960m (I can also not find an option in my bios to only us the igpu) - microcode is installed aswell.

Finally when it doesn't give an error in the recovery mode it doesn't like installing anything (packages) or updating sources. There are no keys valid and only one source.

My system has an intel i5 and nvidia gtx 960m. And kali 2016.2 64bit

Any help would be appreciated.