Hi everyone I am having trouble getting my adapter to find any networks.

Very similar to this thread: https://forums.kali.org/showthread.p...networks-shown

I am using an Alfa AWUS036NEH wireless adapter

I have tried the wireless adapter with
VMware + kali Linux 2017.1 = no networks found (tried with the 7 year old compat drivers as stated in the above thread)
VMware + kali Linux 2016.1 = no networks found
VMware + BT5r3 = no networks found
Virtual Box + kali linux 2016.1 = no networks found

I've searched about the wireless card and it should be compatible.. When its plugged into to my windows machine, it finds all networks, including my home network and can connect to it easily, but when i try in any version of Kali, no networks are found.

iwconfig: (i cannot C+P from my vm so i will type)

lo = no wireless exensions

wlan0 = IEEE 802.11BGN ESSID:off/any
mode:managed access point: not-associated tx-power=20 dbm
retry long limit: 7 RTS thr:off Fragment thr:off
power management:on
eth0 =no wireless exensions
I am not good with any version of Linux and I am struggling to find out how to fix this?

I tried on so many different vm/vb builds so i would of thought that it would of worked at least once..

Anyone got any ideas oh what im doing wrong?