Custom build Terminal not working


For a while I'm trying to build a small custom build Kali Image. Therefor I use the 'normal' Guide: Link

The only changes I've made are:
- SSH active as described in this tutorial
- I've added a few packages to kali-config/variant-gnome/package-lists/kali.list.chroot and instead of using the full version I've changes this to Forensics

I'm working in a 32bit Kali environment, so automatically there is also a 32bit Kali being build. The strange thing is, the first time I've builded an ISO it worked. But after that every ISO I've made and tried get's the same issue. When I boot (the idea is making a custom live bootable USB) to the live version of my custom build ISO, the terminal is not working. When I try to use it, it keeps loading and then stops. Never any screen has been shown. I've tried it more than 10 times.

I've tried many things, started multiple times over and over, reinstalled (multiple times) my environment where I build this custom ROM in VMWare, but somehow only the first install succeeded..
I've also tried on the building environment to change the /etc/default/locale, but after building the image, the same problem appears.

Does anyone knows whether I'm hitting a bug, or am I doing something wrong? I'm trying to keep it as easy as possible. Or is there a workaround?

Thanks in advance!