Results 1 to 2 of 2

Thread: Unable to Install to USB

  1. #1
    Join Date
    My Basement, USA

    Unable to Install to USB

    I have a curious case where I'm unable to install Kali Linux (or really any Linux) onto any of my USB drives. It has never been a problem before. Well, technically it was a problem when I was using a USB 3.0 stick in my USB 3.0 port. I later read that at that time (not sure if it's changed since then) that Linux was unable to boot from USB 3.0 ports. Regardless, that is not my issue this time.

    I have tried with 1 USB 3.0 capable stick and 2 USB 2.0 sticks (all with my USB 2.0 ports ONLY) to install Kali Linux onto the drives. I have installed Kali Linux at some point or another on all of my USB sticks (I think I own 5 at this point?) and never had a problem. Typically the procedure goes like this.
    [root@archlinux ~]# nwipe /dev/sdc
    [root@archlinux ~]# sync
    [root@archlinux ~]# dd if=/root/downloads/kali-linux.iso of=/dev/sdc bs=512k status=progress && sync
    Then I reboot and select my USB stick.

    However, lately I have been using the same procedure, and my USB sticks don't show up in the boot menu. I get the choice to boot from my regular HDD, or Network boot, and that's it. I thought maybe it was just the latest version of Kali that was the issue even though the sha256 checksum matched perfectly, so I tried it with a fresh download of Arch Linux (my main distro of choice and currently installed to my HDD) and still it would not show up in my boot menu. I would really love to have a persistent Kali installation on my 64GB or 256GB USB drives. What information do you need in order to help me diagnose why this is an issue now when it never has been before? Thank you in advance for anyone taking the time to help me sort this out.

  2. #2
    Join Date
    Is there a folder efi in your bootable USB?

Similar Threads

  1. Replies: 8
    Last Post: 2016-01-12, 15:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts