Results 1 to 7 of 7

Thread: unable to install kali full unmet depencies

  1. #1
    Join Date
    2017-Aug
    Posts
    3

    Unhappy unable to install kali full unmet depencies

    Hey all, i hope somebody can help resolve this issue with me.

    Steps before problem occured:
    - downloaded the image for the Odroid-C2
    - DD-ed the image to micro-sd card.
    - resized the 2nc partition
    - booted successfully into kali
    - apt-get update && apt-get upgrade
    - apt-get install kali-linux-full

    And there, in the last step, apt could not install kali-linux-full due to unmet dependencies.
    It was unable to install beef-xss.

    Trying to apt-get install beef-xss results in another missing dependency, ruby-therubyracer.
    therubyracer cannot be installed from apt, so I tried gem install therubyracer were I encountered more errors.

    Searching the web I've found only a few threads, but most are about issues when beef-xss is already installed.
    The only one that seems to hit the nail is this issue over a year old at https://bugs.kali.org/view.php?id=3634

    Could somebody help me, point me in the right directions?
    Many thanks in advance!

  2. #2
    Join Date
    2016-Dec
    Posts
    223
    When you mention failure, show the errors.

    Instead of doing apt-get upgrade, do a dist-upgrade.

    But in case of unmet dependencies, you can try apt-get -f install.

  3. #3
    Join Date
    2017-Aug
    Posts
    3
    Sorry, forgot to mention I did dist-upgrade and apt-get -f install as well.
    And I didn't think those Ruby errors would matter here in the forums. But for full-disclosure I've post it on pastebin, https://pastebin.com/9ry4SqKZ

    Should I not been using the image from https://www.offensive-security.com/k...ux-arm-images/ but instead use armhf image?

  4. #4
    Join Date
    2017-Aug
    Posts
    3
    Anyone any pointers? Doubt I'm the only one running into this.

  5. #5
    Join Date
    2016-Dec
    Posts
    223
    If you could post the whole error, then maybe. If not, then my answer is Google for the error.

  6. #6
    Join Date
    2018-Jan
    Posts
    4
    Same problem here
    did apt-get update apt-get dist-upgrade then apt-get install kali-linux-full
    it went like this: and i tried apt-get -f install as suggested - still no loving.

    root@kali-arm64:~# apt-get install kali-linux-full
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kali-linux-full : Depends: beef-xss but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    root@kali-arm64:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@kali-arm64:~#

    Update 2-25-2018: I have found several other people running into this same problem.... nobody has come forward either in Kali.org or the Odroid forum with a solution or saying they were able to successfully install anything other than the basic (nearly no tools) Kali install on an Odroid C series. (32 bit C0 or C1, C1+ OdroidC distro or C2 64 bit OdroidC2 distro). Doesn't look like you can install the metapackages - either kali-linux-full or kali-Linux-wireless - and another user said kali-Linux-web ... all in all - no point in running Kali on an Odroid if you can't get any meaningful tools installed. I tried 2017.1, 2017.3 and 2018.1 - none of them worked. Just want to save everybody some time and effort and frustration.
    Last edited by muddy; 2018-02-25 at 15:25.

  7. #7
    Join Date
    2014-Feb
    Posts
    210
    Quote Originally Posted by muddy View Post
    Same problem here
    did apt-get update apt-get dist-upgrade then apt-get install kali-linux-full
    it went like this: and i tried apt-get -f install as suggested - still no loving.

    root@kali-arm64:~# apt-get install kali-linux-full
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kali-linux-full : Depends: beef-xss but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    root@kali-arm64:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@kali-arm64:~#

    Update 2-25-2018: I have found several other people running into this same problem.... nobody has come forward either in Kali.org or the Odroid forum with a solution or saying they were able to successfully install anything other than the basic (nearly no tools) Kali install on an Odroid C series. (32 bit C0 or C1, C1+ OdroidC distro or C2 64 bit OdroidC2 distro). Doesn't look like you can install the metapackages - either kali-linux-full or kali-Linux-wireless - and another user said kali-Linux-web ... all in all - no point in running Kali on an Odroid if you can't get any meaningful tools installed. I tried 2017.1, 2017.3 and 2018.1 - none of them worked. Just want to save everybody some time and effort and frustration.
    You can't install kali-linux-full due to it having a dependency on beef-xss.

    beef-xss can't be installed because it (and a few other packages) depend on ruby-therubyracer - unfortunately, ruby-therubyracer does not have a new enough version of libv8 to support arm64 (it's version of v8 is 3.15.11.1 iirc) which is from 2013, when arm64 didn't really exist. Until upstream pulls in a newer version of libv8 (and they are working on it - you can follow along at https://github.com/cowboyd/libv8/pull/258 .

    Now, you can't install the *metapackages* kali-linux-all, kali-linux-full, or kali-linux-web, however, kali-linux-wireless and the other meta packages install just fine. You can still look at the packages that the metapackages pull in, and pull them in manually until upstream has fixed the issue.

    ARM64 isn't exactly widespread, so efforts from people who do have the hardware are greatly appreciated by upstream projects.

    Note: this only applies to arm64 devices. The 32bit C0, C1, C1+ should all work fine as they are armhf and fully supported by that ruby-therubyracer.

Similar Threads

  1. Replies: 1
    Last Post: 2014-08-03, 01:35

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •