Results 1 to 1 of 1

Thread: Kali on RPI

  1. #1
    Join Date

    Kali on RPI

    Hey, I've been trying and trying to get Kali Linux on my Raspberry Pi for a couple days now and I have had no luck.
    I have tried the following things to try to get it working (my main problem is booting up with Kali):

    Using windiskimager32 to write the armel image, the 64 bit full image, and the rpi 2/3 image to the 32gb micro sd card that i have.
    Using NOOBS to throw the 64 bit ISO/folder extracted from the ISO & the rpi 2/3 img into the /os/ directory.
    Tried redownloading NOOBS & redownloading the different distros with no luck.
    Tried getting the RPI to boot from a USB that was burned with the 64bit ISO image that I know has worked in the past with my W10 main PC.
    I've validated the SHA256sums successfully with the 64bit and the armel image, but unsuccessfully with the rpi2/3 image that i downloaded from the kali site- the sha256sums did not match for the rpi2/3 img file.
    Tried using dd command on terminal emulator but getting errors(is a directory) trying to see whats up with that.

    I've gotten the RPI to boot with NOOBS alone and used NOOBS to download and boot up Raspbian working well.
    I went on to the RPI forums first before this and they didn't offer any help(thanks guys) and I've tried following the tutorial to get klinux into the rpi using the dd command, but i only have one sd card to write on to and the terminal emulators ive tried using did not work at all.

    Any help would be appreciated, I've been trying Kali over and over with a VM on my windows pc which goofed too much, and tried dual booting windows and kali, barely saving my computer from being bricked and losing all my data.
    Thank you!!!!!!!!!!

    P.S. Raspberry Pi 3 Model B using HDMI & working internet connection

    update: doing intensive tests to find defects, nothing found as of yet.
    update update: no defects found using fakeflashtest, h2testw, and windows-----also getting dd error is a directory, trying to figure that out i've had the error before
    Last edited by nAZklX; 2017-08-21 at 19:21.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts