Results 1 to 5 of 5

Thread: Trouble with mac changing in kali running on VM

  1. #1
    Join Date

    Trouble with mac changing in kali running on VM

    Hello. I am trying to find soludion for this problem. I am running kali on virtual machine. My computer is connected to the internet with ethernet cable. When I change my mac address to random one with macchanger, I lose internet connection and can't get it back unless I change mac address back to permanent one.

    I tried to change my mac address this way:

    service network-manager stop
    ifconfig eth0 down
    macchanger -r eth0
    ifconfig eth0 up
    service network-manager start

    And different combinations with these commands. It did not worked. I also tried to physically disconnect and reconnect my machine by taking off the cable from the machine and plugging it back on.

    I am new to Linux and networking, so maybe I miss something silly. I tried to do some research on the forums but it did not helped me.

    My question is: How to change my mac address to random one (-r) on Kali that is running on virtual machine?

    If you have any questions to me, please do ask.

  2. #2
    Join Date
    The virtualization software most likely knows what MAC address is allocated to your VM because you can edit it.

    To change the MAC in vmware workstation (and probably player/fusion), go to VM menu then click on Settings. From there, select the network adapter, click advanced and change the MAC. You might have to reboot the VM.

  3. #3
    Join Date
    I was looking the way to make Kali on VM generate it's mac address automatically every time I boot OS. I guess it is not possible or not that easy.
    Internet works when I change mac address manually in VM settings. Thank you for your help, appreciate it.

  4. #4
    Join Date
    To guy3111

    The matter of macchanger versus network-manager(NM) is a long standing problem and well covered in this forum.

    Your series of commands is actually bringing into play two(2) different macchanging systems; the manual macchanger commands you typed in the terminal window(TW) and the macchanging system embedded within NM itself. Hence you are changing the mac address thru the TW and then starting NM. When you start NM the mac address setting in NM for the device will override the TW commands

    MTeams does not use VM or ethernet however here are some links to approach the problem. There are several solutions.

    Of specific use to you, read the comments by hon3yb33 near the end of the second link above.

    Musket Teams

  5. #5
    Join Date
    To mmusket33

    The way I was trying to automatically change my mac address at booting is identical to hon3yb33 solution. The problem was that I had no internet connection after reboot. I partially solved this problem with a help from Mister_X.

    Thank you for sharing information about the problem that I was completelly unaware of. I am learning and this information is going to be very usefull to me.

Similar Threads

  1. Trouble running apt-get update offline
    By yetta in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-04-20, 16:51
  2. Trouble installing / running on old Toshiba Laptop
    By DairyMilk in forum Installing Archive
    Replies: 3
    Last Post: 2016-04-15, 20:18
  3. Having trouble running uniscan
    By linccracker in forum General Archive
    Replies: 2
    Last Post: 2013-03-14, 20:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts