Results 1 to 3 of 3

Thread: Surface laptop keyboard not working/recognized

  1. #1
    Junior Member
    Join Date
    Aug 2017
    Posts
    2

    Surface laptop keyboard not working/recognized

    Hello, Let me first start off by saying I am relatively new to Linux as a whole and have spent around 15-20 hours of my time trying to get the surface laptop keyboard to work. I have tried 2017-W34 and the track-pad won't work at all in that version or any mouse I try to connect to the surface laptop so that's a no go. In my current config Kali doesn't even seen the keyboard as being connected. I can boot into windows and find the device ID and I attempted to add it manually in to a folder(i forgot the name of it i tried this very early on) and it would not work. I think adding the device ID will be the solution but I am not sure where exactly would be the right place to add it in. I have tried re-installing kali several times and using the ubuntu and debian patches floating around online and to no avail they don't work. I tried this one right before I wrote this up, https://lkml.org/lkml/2014/11/3/1016. See below as to where I am at now.

    I attempted this https://forums.kali.org/showthread.p...-Surface-Pro-4 and it didn't fix it.

    Using 2017.1 I updated with below commands
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade
    restart
    sudo apt-get install linux-headers-$(uname -r)
    restart
    (tried the keyboard nothing)

    My current Uname -a
    Linux kali 4.12.0-kali1-amd64 #1 SMP Debian 4.12.6-1kali1 (2017-08-18) x86_64 GNU/linux

    What is weird to me is how it updated to "Kali1" because looking at others outputs it seems they have Kali 3/4. Again I am new so it I am not sure what the difference is but I do know 1 is before 4 so something must be jacked up there. I am seriously out of ideas and I am exhausted trying to get this to work and my lack of knowledge is certainly probably stopping me but I have tried googling everything and piecing it all together but I am at a stand still now. I am sure someone has a fix for this and I would greatly appreciate it I will try ANYTHING you post that you can think of, if you need to see any outputs let me know.

  2. #2
    Junior Member
    Join Date
    May 2016
    Posts
    6
    Having some sort of the same issue I start my Dell then kali does some crazy like fuzzy screen then I normally start on to the login screen but neither my kayboard or Mousepad Work and everything was working really fine but I just if over night and it stopped working like on a really long frozen screen I tried formatting into 0's and reinstalling Kali but all to the same result and I cant do no restore cause well I deleted that partition I live USB into my machinge but even the Live as issues Im starting to woder that it some hardware related but trying to waste all my software options before I start unscrewing this baby up Ive been hoping its not a kernel panic but Ive seen the logs and that doesnt seem the case

  3. #3
    Member
    Join Date
    Dec 2016
    Posts
    79
    You need "drivers" for your device. Since kali runs on the Debian desktop. Find out if your device has available drivers at the Debian Linux Webpage. This isn't a Kali Linux problem per sa.
    But they try to pick the best desktop to run off of. Also Ubuntu is a good place.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •