Results 1 to 4 of 4

Thread: kali kernel 4.12 virtualbox error

  1. #1
    Join Date
    2013-Apr
    Posts
    160

    kali kernel 4.12 virtualbox error

    apt-get install --reinstall virtualbox-dkms
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
    Need to get 0 B/659 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    (Reading database ... 609389 files and directories currently installed.)
    Preparing to unpack .../virtualbox-dkms_5.1.18-dfsg-1_all.deb ...

    ------------------------------
    Deleting module version: 5.1.18
    completely from the DKMS tree.
    ------------------------------
    Done.
    Unpacking virtualbox-dkms (5.1.18-dfsg-1) over (5.1.18-dfsg-1) ...
    Setting up virtualbox-dkms (5.1.18-dfsg-1) ...
    Loading new virtualbox-5.1.18 DKMS files...
    Building for 4.12.0-kali1-686-pae
    Building initial module for 4.12.0-kali1-686-pae
    Error! Bad return status for module build on kernel: 4.12.0-kali1-686-pae (i686)
    Consult /var/lib/dkms/virtualbox/5.1.18/build/make.log for more information.
    Job for virtualbox.service failed because the control process exited with error code.
    See "systemctl status virtualbox.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript virtualbox, action "restart" failed.
    ● virtualbox.service - LSB: VirtualBox Linux kernel module
    Loaded: loaded (/etc/init.d/virtualbox; generated; vendor preset: enabled)
    Active: failed (Result: exit-code) since Fri 2017-08-25 09:35:45 CST; 6ms ago
    Docs: man:systemd-sysv-generator(8)
    Process: 7560 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

    Aug 25 09:35:45 debain systemd[1]: Starting LSB: VirtualBox Linux kernel module...
    Aug 25 09:35:45 debain virtualbox[7560]: Loading VirtualBox kernel modules...No suitable module for running kernel found ... failed!
    Aug 25 09:35:45 debain virtualbox[7560]: failed!
    Aug 25 09:35:45 debain systemd[1]: virtualbox.service: Control process exited, code=exited status=1
    Aug 25 09:35:45 debain systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
    Aug 25 09:35:45 debain systemd[1]: virtualbox.service: Unit entered failed state.
    Aug 25 09:35:45 debain systemd[1]: virtualbox.service: Failed with result 'exit-code'.

  2. #2
    Join Date
    2013-Apr
    Posts
    160
    solved after apt-get update and apt-get dist-upgrade

  3. #3
    Join Date
    2017-Nov
    Posts
    2
    I'm having the same problem and the updates and upgrades do not help. I was trying to install virtualbox onto my laptop which is running kali Linux. I get some errors when installing virtualbox itself such as "Failed to start LSB: Linux kernel module.", after it finishes installing I start the virtualbox service which will open up the program window. But I get a error in the terminal saying "The character device /dev/vboxdrv does not exist. Please install the virtualbox-dkms package and the appropriate headers, most likely linux-headers-686". I have tried installing both of these packages but the terminal says they are already installed and up to date. I have also tried to use apt-get upgrade and apt-get upgrade. Nothing seems to make a difference.

    Details:

    Kali Version(kali-rolling, GNOME Shell 3.26.1, 32 bit)
    Installed on my Lenovo Laptop
    I have tried updating my system as well as using dpkg-reconfigure. I have tried updating the headers, nothing seems to help.

    -Thanks

  4. #4
    Join Date
    2018-Jan
    Posts
    1
    Hi,

    First of all i want to introduce my self because I'm a new member in here.
    The solution that I found after several try is to download the Virtual Box from Oracle sites https://download.virtualbox.org/virt...eezy_amd64.deb,
    make dpkg -i dpkg -i virtualbox-5.2_5.2.6-120293~Debian~wheezy_amd64.deb, and you will got dependencies error but is okay, use apt-get --fix-broken will install the dependencies that's needed by the application, but after that I used again this command dpkg -i virtualbox-5.2_5.2.6-120293~Debian~wheezy_amd64.deb and it's works.

    Cheers

Similar Threads

  1. VirtualBox kernel issues?
    By Lodos in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-10-20, 22:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •