Results 1 to 6 of 6

Thread: Problem with wireless internet and ALFA AWUS036ACH in Kali Linux 4.9.0

  1. #1
    Junior Member
    Join Date
    Aug 2017
    Posts
    1

    Exclamation Problem with wireless internet and ALFA AWUS036ACH in Kali Linux 4.9.0

    Hello

    I'm experiencing problems getting the AWUS036ACH working with Kali Linux, canít get the adapter working and canít find any Wi-Fi hotspots with it. On Windows 10, it works fine. And my wifi in general is causing some problems.

    Iíve tried in

    - Kali Live (DESKTOP and LAPTOP)
    - Dual Boot (along W10)
    - VM

    In the Dual Boot, I canít even get my usual wireless network adapter working, and I have to use ethernet cable to have a connection to the internet.

    In Live, usual network adapter works fine.

    In VM the usual wireless adapter works fine, but when I try to connect AWUS036ACH it wonít work.
    (Shows up on lsusb and iwconfig after bridging my VM, but canít use it as wireless adapter, shows no Wi-Fi hotspot)

    Iíve tried to install the drivers from ALFA NETWORK (https://www.alfa.com.tw/download_sho...ejqbhb&x=0&y=0) [the driver for Linux kernel 3.16]

    Iíve also tried to install the software for the chipset, the Realtek-RTL8812AU with;
    Code:
    apt-get install realtek-rtl8812xxau-dkms
    (updating system first with apt-get update and apt-get upgrade)


    In dual boot (without AWUS connected) I get


    lspci

    Code:
    root@kali:~# lspci
    00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
    00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
    00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
    00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
    00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
    00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
    00:1f.0 ISA bridge: Intel Corporation B75 Express Chipset LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
    01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
    04:00.0 Network controller: Ralink corp. RT5592 PCIe Wireless Network Adapter

    lsusb

    Code:
    root@kali:~# lsusb
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 045e:0768 Microsoft Corp. Sidewinder X4
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 003: ID 1532:0043 Razer USA, Ltd 
    Bus 003 Device 005: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    dmesg | tail

    Code:
    root@kali:~# dmesg | tail
    [   12.133824] Bluetooth: HCI socket layer initialized
    [   12.133826] Bluetooth: L2CAP socket layer initialized
    [   12.133832] Bluetooth: SCO socket layer initialized
    [   12.567797] Netfilter messages via NETLINK v0.30.
    [   13.425652] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   13.453743] r8169 0000:03:00.0: firmware: direct-loading firmware rtl_nic/rtl8168e-3.fw
    [   13.575474] r8169 0000:03:00.0 eth0: link down
    [   13.575514] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   27.718293] usb 3-3: USB disconnect, device number 2
    [   46.059842] fuse init (API version 7.26)


    Then I connect the AWUS, and get:



    dmesg | tail

    Code:
    root@kali:~# dmesg | tail
    [ 1522.154780] usb 3-3: Product: 802.11n NIC
    [ 1522.154781] usb 3-3: Manufacturer: Realtek
    [ 1522.154783] usb 3-3: SerialNumber: 123456
    [ 1531.350319] usb 3-3: USB disconnect, device number 4
    [ 1548.103916] usb 3-3: new high-speed USB device number 5 using xhci_hcd
    [ 1548.244438] usb 3-3: New USB device found, idVendor=0bda, idProduct=8812
    [ 1548.244441] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 1548.244443] usb 3-3: Product: 802.11n NIC
    [ 1548.244444] usb 3-3: Manufacturer: Realtek
    [ 1548.244445] usb 3-3: SerialNumber: 123456


    ifconfig -a eth0

    Code:
    eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether d4:3d:7e:9c:0c:73  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



    With or without AWUS, I get on dual boot:


    iwconfig

    Code:
    root@kali:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.



    Without AWUS connected, it only shows ethernet settings under network settings, and with the AWUS connected I can see Wi-fi settings, but canít find any hotspots.

    Iíve tried getting a solution from google searches and the following links, but without any luck.
    https://docs.kali.org/installation/t...-driver-issues
    https://forums.kali.org/showthread.p...Network-Access

    Thank you for any help, it is greatly appreciated

  2. #2
    Junior Member
    Join Date
    Aug 2017
    Posts
    18
    What happened when you installed the realtek-rtl88xxau-dkms package? Which system did you install it to (kali alongside win10, dual booting?)?
    What is the output of ifconfig -a (on Kali dual boot)?
    Can you work out what driver (module) your kali live is using when it has the onboard ralink chipset working?

  3. #3
    Junior Member
    Join Date
    Aug 2017
    Posts
    18
    This page
    https://github.com/mareksuscak/asus-pce-n53-linux
    should help with getting the onboard card working.
    Let us know if it helps.

  4. #4
    Junior Member
    Join Date
    Aug 2017
    Posts
    3
    Hi, i have an AWUS model:AWUS036H, i do experience same problem sometimes on Kali Rolling 2017.1 from USB with persistence.

    Here is what i do, i restart my laptop with unplugging then plugging the AWUS beforehand and trying to change the USB port, sometimes i need to make it for a few tries before it starts working again, i suspect its overheating or something.

    However in my case i also add to the boot commend the following parameters to fix a log flooding problem:

    pci=noaer,nomsi

  5. #5
    Junior Member
    Join Date
    Sep 2017
    Posts
    2
    similar problem w/ AWUS036ACH
    Linux kali 4.4.50-v7 #1 SMP Fri Apr 21 01:18:29 CDT 2017 armv7l GNU/Linux on Raspberry pi3Bus 001 Device 005: ID 046d:c534 Logitech, Inc. Unifying Receiver

    realtek-rtl88xxau-dkms is already the newest version (5.1.5~20170828-0kali1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Bus 001 Device 004: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    however, device does not show w/ iwconfig/ifconfig

    help is appreciated.

  6. #6
    Junior Member
    Join Date
    Aug 2017
    Posts
    18
    Try
    Code:
    ifconfig -a
    it will show interfaces which are not 'up'

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •