Results 1 to 19 of 19

Thread: Monitor Mode Problem HELP!

  1. #1
    Join Date
    2017-Aug
    Posts
    5

    Monitor Mode Problem HELP!

    main operating system is Debian 9.1
    Code:
    Linux debian 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u3  (2017-08-06)  x86_64 GNU/Linux
    uname -v :
    Code:
    #1 SMP Debian 4.9.30-2+deb9u3  (2017-08-06)
    virtualized kali info :
    Code:
    Linux kali 4.12.0-kali1-amd64 #1 SMP Debian 4.12.6-1kali6 (2017-08-30) x86_64 GNU/Linux
    i have use kali on vmware and i use usb wireless adaptor TP LINK TL-WN722N. wireless adapter driver is

    rtl8188EUS_linux_v4.3.0.8_13968.20150417. i have installed from https://github.com/mfruba/kernel (said it was compatible with the kernel version)

    Adapter have running but when i want to change usb's mode as monitor encounter this error :
    Code:
    #iwconfig wlan0 mode monitor
    Error for wireless request "Set Mode" (8B06) :
        SET failed on device wlan0 ; Invalid argument.

  2. #2
    Join Date
    2013-Jul
    Posts
    819
    To r0b0

    Go here and read page two the last few entries in the thread

    https://forums.kali.org/showthread.p...ghlight=WN722N

    Musket Teams

  3. #3
    Join Date
    2017-Aug
    Posts
    5
    I read the page you shared. my usb adapter's version v2.

    must i buy new adapter be v1 Must i buy adapter of version v1?

    or is there another resolve? etc. new driver for v2 version? ,

  4. #4
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    sudo airmon-ng
    sudo airmon-ng check
    sudo airmon-ng check kill
    sudo airmon-ng start wlan0


    How do you know wlan0 is the right interface for your wifi adapter? wlan0 is generally assigned to internal wifi adapter. It can be different for external one.
    Last edited by _defalt; 2017-09-03 at 06:54.

  5. #5
    Join Date
    2017-Aug
    Posts
    5
    Quote Originally Posted by _defalt View Post
    sudo airmon-ng
    sudo airmon-ng check
    sudo airmon-ng check kill
    sudo airmon-ng start wlano


    How do you know wlan0 is the right interface for your wifi adapter? wlan0 is generally assigned to internal wifi adapter. It can be different for external one.
    I tried the above codes

    sudo airmon-ng :
    Code:
    PHY	Interface	Driver		Chipset
    
    null	wlan0		r8188eu
    sudo airmon-ng check :
    Code:
    Found 4 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to run 'airmon-ng check kill'
    
       PID Name
      1871 NetworkManager
      1885 wpa_supplicant
      1888 dhclient
      1896 dhclient
    sudo airmon-ng check kill :
    Code:
    Killing these processes:
    
       PID Name
      1885 wpa_supplicant
      1888 dhclient
    sudo airmon-ng start wlano :

    Code:
    PHY	Interface	Driver		Chipset
    
    null	wlan0		r8188eu
    How do you know wlan0 is the right interface for your wifi adapter? wlan0 is generally assigned to internal wifi adapter. It can be different for external one.
    how do i know or change which have its wlan0 interface?
    i disconnect usb adapter of pc and use iwconfig but wlan0 interface disappear

  6. #6
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by r0b0 View Post
    sudo airmon-ng start wlano :
    It is sudo airmon-ng start wlan0

  7. #7
    Join Date
    2017-Aug
    Posts
    5
    i use iwconfig and the mac adress appear as modem's mac adress.
    i think wlan0 interface the modem's interface. how can i change with usb adapter?

  8. #8
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by r0b0 View Post
    i use iwconfig and the mac adress appear as modem's mac adress.
    i think wlan0 interface the modem's interface. how can i change with usb adapter?
    Don't pay attention to it. wlan0 is the interface name which is automatically assigned by network-manager. Have you re-run the above commands?

  9. #9
    Join Date
    2017-Aug
    Posts
    5
    yes i tried again but same result unfortunately

  10. #10
    Join Date
    2017-Sep
    Location
    On your webcam
    Posts
    9
    Quote Originally Posted by r0b0 View Post
    I read the page you shared. my usb adapter's version v2.

    must i buy new adapter be v1 Must i buy adapter of version v1?

    or is there another resolve? etc. new driver for v2 version? ,
    Nope must be V1 for the 722N

  11. #11
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by r0b0 View Post
    yes i tried again but same result unfortunately
    Can you show the output again? This time type commands correctly.

  12. #12
    Join Date
    2017-Sep
    Posts
    3
    Quote Originally Posted by r0b0 View Post
    yes i tried again but same result unfortunately
    This is not correct. The v2.0 chipset fully supports monitor mode. It does require installing some drivers that enable support.

    https://github.com/mfruba/kernel

    I followed the instructions (all three lines) and monitor mode works perfectly on my TL-WN722N v2.0 with the Realtek RTL8188EUS chipset.

  13. #13
    Join Date
    2017-Sep
    Posts
    6
    Quote Originally Posted by qmech View Post
    This is not correct. The v2.0 chipset fully supports monitor mode. It does require installing some drivers that enable support.

    https://github.com/mfruba/kernel

    I followed the instructions (all three lines) and monitor mode works perfectly on my TL-WN722N v2.0 with the Realtek RTL8188EUS chipset.
    Kali Live encrypted persistence. It remembers my packages, not sure about the kernels.

    I bought the same device (V2, apparently. When trying to "make" the drivers according to the referenced site, all I get is this:

    Code:
    root@kali:~/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417# make
    "******************************************"
    "NO SKRC,we will use default KSRC"
    "******************************************"
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.0-kali1-amd64/build M=/root/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417  modules
    make[1]: *** /lib/modules/4.12.0-kali1-amd64/build: No such file or directory.  Stop.
    Makefile:1368: recipe for target 'modules' failed
    make: *** [modules] Error 2
    I have run all update commands

    Code:
    apt-get update
    apt-get -y upgrade
    apt-get -y dist-upgrade
    and it swears up and down that 4.12.0-kali2-amd64 is installed, but it won't boot it.

    Code:
    uname -r
    still shows
    Code:
    4.12.0-kali1-amd64
    and won't budge.

    So I guess the first step for me is to get Kali to boot the most recent kernel so the makefile knows where to go. But I don't know how to do this, and there doesn't appear to be an update-grub or anything. Or maybe I just misunderstand the whole shebang.

    So what do I do now?

  14. #14
    Join Date
    2016-Dec
    Posts
    133
    Quote Originally Posted by Bl4ck_P4l4d1n View Post
    Kali Live encrypted persistence. It remembers my packages, not sure about the kernels.

    I bought the same device (V2, apparently. When trying to "make" the drivers according to the referenced site, all I get is this:

    Code:
    root@kali:~/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417# make
    "******************************************"
    "NO SKRC,we will use default KSRC"
    "******************************************"
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.0-kali1-amd64/build M=/root/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417  modules
    make[1]: *** /lib/modules/4.12.0-kali1-amd64/build: No such file or directory.  Stop.
    Makefile:1368: recipe for target 'modules' failed
    make: *** [modules] Error 2
    I have run all update commands

    Code:
    apt-get update
    apt-get -y upgrade
    apt-get -y dist-upgrade
    and it swears up and down that 4.12.0-kali2-amd64 is installed, but it won't boot it.

    Code:
    uname -r
    still shows
    Code:
    4.12.0-kali1-amd64
    and won't budge.

    So I guess the first step for me is to get Kali to boot the most recent kernel so the makefile knows where to go. But I don't know how to do this, and there doesn't appear to be an update-grub or anything. Or maybe I just misunderstand the whole shebang.

    So what do I do now?
    Ifconfig wlan0 down
    Iwconfig wlan0 mode moniter
    Ifconfig wlan0 up

  15. #15
    Join Date
    2017-Sep
    Posts
    6
    Quote Originally Posted by bigbiz View Post
    Ifconfig wlan0 down
    Iwconfig wlan0 mode moniter
    Ifconfig wlan0 up
    Since my last response, I also created a new VM full install to VDI) and ran only the update commands

    Code:
    apt-get update
    apt-get upgrade
    apt dist-upgrade
    And then tried to make again:

    Code:
    oot@kali:~/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417# make
    "******************************************"
    "NO SKRC,we will use default KSRC"
    "******************************************"
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.0-kali2-amd64/build M=/root/Desktop/kernel/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417  modules
    make[1]: *** /lib/modules/4.12.0-kali2-amd64/build: No such file or directory.  Stop.
    Makefile:1368: recipe for target 'modules' failed
    make: *** [modules] Error 2
    Response from above commands afterward:

    Code:
    root@kali:~# ifconfig wlan0 down
    root@kali:~# iwconfig wlan0 mode monitor
    Error for wireless request "Set Mode" (8B06) :
        SET failed on device wlan0 ; Invalid argument.
    root@kali:~# ifconfig wlan0 up
    So no dice.

    In case I haven't said, thanks for the way you guys keep trying. There's got to be a way.

  16. #16
    Join Date
    2017-Sep
    Posts
    6
    OK, I've been talking with the guy who posted that video on getting it working. He says that the distro he used was 2017-1, NOT 2017-2. I'm in the process of getting the 2017-1 ISO now, but it's slow going as it looks like the official, verified torrent is gone and I have to use a direct link. Just in case someone can help me speed this up, or for future reference, is there anywhere to get the previous, official torrents for such times as these?

    And this sure is a lousy way to try to save $15, assuming the V1 TL-WN722N is still even available.

  17. #17
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by Bl4ck_P4l4d1n View Post
    OK, I've been talking with the guy who posted that video on getting it working. He says that the distro he used was 2017-1, NOT 2017-2. I'm in the process of getting the 2017-1 ISO now, but it's slow going as it looks like the official, verified torrent is gone and I have to use a direct link. Just in case someone can help me speed this up, or for future reference, is there anywhere to get the previous, official torrents for such times as these?

    And this sure is a lousy way to try to save $15, assuming the V1 TL-WN722N is still even available.
    Nothing has much changed in 2017.2 except the kernel version. Ask that person what binaries did he install before compiling the driver from its source.

    Have you installed linux-headers? sudo apt-get install linux-headers-$(uname -r)

  18. #18
    Join Date
    2016-Dec
    Posts
    133
    When I use my usb adapter, my interface for the adapter is usually wlan1. Where my internal wifi chip is always wlan0. Try
    ifconfig wlan1 down
    Iwconfig wlan1 mode moniter
    Ifconfig wlan1 up
    If you didnt get an interface wlan1 under
    the command airmon-ng. Try rfkill to see if anything is locking up your interface. Rfkill wlan1 or something like that, rfkill -h will give you better info.

  19. #19
    Join Date
    2017-Oct
    Posts
    2
    I think problem in /lib/modules/ folder
    there is only 4.12.0-kali1-64amd and we need 4.12.0-kali2-64amd, but i have no idea how to instal kali 2 module

Similar Threads

  1. Alfa AWUS036H Problem. wierd interface name and error log for monitor mode
    By HaraldGer123 in forum TroubleShooting Archive
    Replies: 16
    Last Post: 2016-06-08, 14:18
  2. Reaver Monitor Mode problem, Wifi Bug
    By DatIsNice in forum General Archive
    Replies: 4
    Last Post: 2016-05-26, 18:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •