Please tell me how to disable the annoying beep sound right after booting Kali Linux in UEFI mode.

I am using latest "kali-linux-2017.2-amd64.iso". I have tried removing the "^G" sign from the "/isolinux/menu.cfg" file. When booting in BIOS/Legacy mode, there is no beep, thats okay. But when booting in UEFI mode, there is beep. How to get rid of it?

Also I have tried this method (modyfing the ISO with hexeditor and then burning to USB with dd). The same result as above (beep is still there when booting in UEFI mode).

Thanks for any advices.

And I really would like to know (especially from Kali Linux maintainers/devs), why the hell is this annoying crap "feature" enabled by default...

Btw., I am creating this thread again because the previous one was deleted by some moderator who proably doesnt understand that there is difference between BIOS and UEFI. There is no single sentence in the documentation about disabling this annoying beep, and all forum threads only says "remove the ^G sign" or "use the hex method" which disables this beep sound only in BIOS mode, not UEFI.