Results 1 to 4 of 4

Thread: Issues with therubyracer dependency

  1. #1
    Join Date
    2017-Sep
    Posts
    1

    Issues with therubyracer dependency

    Dear all,

    I am an Linux amateur who is trying out Kali on my Odroid C2 device.
    With limited knowledge and plenty of online searches, I've managed to dd the Kali image onto my device with the following done:

    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    I've tried to do a apt-get install kali-linux and it was successful. However, when I did a apt-get install kali-linux-full, I have the following error:

    The following packages have unmet dependencies
    kali-linux-full : Depends: beef-xss but it is not going to be installed
    E: Unable to correct problems, you have have held broken packages

    I tried to narrow the issue by doing an apt-get install beef-xss and it states:

    The following packages have unmet dependencies
    beef-xss : Depends: ruby-therubyracer (>=0.11.0beta1) but it is not going to be installable
    E: Unable to correct problems, you have have held broken packages

    Please help advise on what can be done to resolve this as my online search did not help in my understanding to solve.

  2. #2
    Join Date
    2018-Jan
    Posts
    4
    Did you ever find a solution for this - I am having the same problem with Kali 2017.1 and Kali 2017.3 - also on a Odroid C2
    It throws the error on apt-get install kali-linux-full and on kali-Linux-wireless - so the install stops...... and the end result is a device without the intended functionality, because very few tools are installed.
    It is not a space issue for me as I have over 90GB free in ext4. Any ideas?

    Update 2-19-2018 Tried Kali 2018.1 - still no go same error.... tried
    apt-get install -f and all the other suggestions I could find - no success. Anyone?

    Update 2-22-2018 - Odroid forum says they cannot be of any help (Kali issue) - and nobody on this forum has any answers regarding this problem, or has reported a successful install, so I can only assume Kali ARM for Odroid C and C2 version 2018.1 is fragged for this platform, and simply does not work. I am putting it away until I have time to check next distro. Hope I can save somebody some time.
    Last edited by muddy; 2018-02-23 at 01:20.

  3. #3
    Join Date
    2014-Feb
    Posts
    233
    Quote Originally Posted by ortha View Post
    Dear all,

    I am an Linux amateur who is trying out Kali on my Odroid C2 device.
    With limited knowledge and plenty of online searches, I've managed to dd the Kali image onto my device with the following done:

    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    I've tried to do a apt-get install kali-linux and it was successful. However, when I did a apt-get install kali-linux-full, I have the following error:

    The following packages have unmet dependencies
    kali-linux-full : Depends: beef-xss but it is not going to be installed
    E: Unable to correct problems, you have have held broken packages

    I tried to narrow the issue by doing an apt-get install beef-xss and it states:

    The following packages have unmet dependencies
    beef-xss : Depends: ruby-therubyracer (>=0.11.0beta1) but it is not going to be installable
    E: Unable to correct problems, you have have held broken packages

    Please help advise on what can be done to resolve this as my online search did not help in my understanding to solve.
    Hi Ortha,

    Unfortunately, the upstream project for ruby-therubyracer uses a very old version of libv8 that does not support arm64. You can install the packages manually (you can `apt show kali-linux-full` and then copy and paste all those to apt-get after removing beef-xss.)

    Until they move to a newer libv8 there's nothing that can be done on our end.

  4. #4
    Join Date
    2014-Feb
    Posts
    233
    For now, until upstream comes up with a better solution, I've pulled beef-xss out of the dependencies on arm64. You should now be able to apt-get install kali-linux-full (or apt-get install kali-linux-all) without running into the issue of packages being missing.

Similar Threads

  1. Beef-xss dependency problem
    By muddy in forum ARM Archive
    Replies: 0
    Last Post: 2018-01-25, 16:36
  2. Unable to install pipelight due to wine-staging dependency Issues
    By yobenjo in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-04-11, 22:02
  3. Dependency is not satisfiable: libc6 (>= 2.15)
    By BaconZombie in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-01-05, 19:09
  4. Reaver/Dependency Installation Issues
    By draco in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-10-05, 21:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •