Results 1 to 2 of 2

Thread: Issues with therubyracer dependency

  1. #1
    Join Date
    2017-Sep
    Posts
    1

    Issues with therubyracer dependency

    Dear all,

    I am an Linux amateur who is trying out Kali on my Odroid C2 device.
    With limited knowledge and plenty of online searches, I've managed to dd the Kali image onto my device with the following done:

    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    I've tried to do a apt-get install kali-linux and it was successful. However, when I did a apt-get install kali-linux-full, I have the following error:

    The following packages have unmet dependencies
    kali-linux-full : Depends: beef-xss but it is not going to be installed
    E: Unable to correct problems, you have have held broken packages

    I tried to narrow the issue by doing an apt-get install beef-xss and it states:

    The following packages have unmet dependencies
    beef-xss : Depends: ruby-therubyracer (>=0.11.0beta1) but it is not going to be installable
    E: Unable to correct problems, you have have held broken packages

    Please help advise on what can be done to resolve this as my online search did not help in my understanding to solve.

  2. #2
    Join Date
    2018-Jan
    Posts
    4
    Did you ever find a solution for this - I am having the same problem with Kali 2017.1 and Kali 2017.3 - also on a Odroid C2
    It throws the error on apt-get install kali-linux-full and on kali-Linux-wireless - so the install stops...... and the end result is a device without the intended functionality, because very few tools are installed.
    It is not a space issue for me as I have over 90GB free in ext4. Any ideas?

    Update 2-19-2018 Tried Kali 2018.1 - still no go same error.... tried
    apt-get install -f and all the other suggestions I could find - no success. Anyone?
    Last edited by muddy; 2 Days Ago at 21:40.

Similar Threads

  1. Beef-xss dependency problem
    By muddy in forum Kali Linux ARM Architecture
    Replies: 0
    Last Post: 3 Weeks Ago, 16:36
  2. Unable to install pipelight due to wine-staging dependency Issues
    By yobenjo in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-04-11, 22:02
  3. Dependency is not satisfiable: libc6 (>= 2.15)
    By BaconZombie in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-01-05, 19:09
  4. Reaver/Dependency Installation Issues
    By draco in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-10-05, 21:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •