Results 1 to 4 of 4

Thread: ALFA AWUS036NHA Not Loading Up In Raspberry Pi 3

  1. #1

    ALFA AWUS036NHA Not Loading Up In Raspberry Pi 3


    I've been trying to get my new ALFA AWUS036NHA to work with my Rpi 3 and yet when I plug it in through a powered usb hub the wifi adapter shows up in lsusb but never in iwconfig or airmon-ng. Apparently it should work without trouble by just plugging it in but that has not been working for me. Any help would be greatly appreciated, I've been re-imaging my micro SD for days now.

    I am currently running the Kali ARM image: "kali-2017.2-rpi3-nexmon.img"

    Here is a sample of code of common commands that requested whenever an issue like this is presented.

    root@kali:~# iwconfig
    wlan0     IEEE 802.11bgn  ESSID:off/any
              Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    lo        no wireless extensions.
    eth0      no wireless extensions.
    root@kali:~# ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet  netmask  broadcast
            inet6 fe80::ba27:ebff:fe78:87c5  prefixlen 64  scopeid 0x20<link>
            ether b8:27:eb:78:87:c5  txqueuelen 1000  (Ethernet)
            RX packets 210481  bytes 307368395 (293.1 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 130935  bytes 10417192 (9.9 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet  netmask
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1  (Local Loopback)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 76:77:dc:84:41:09  txqueuelen 1000  (Ethernet)
            RX packets 3111  bytes 1370855 (1.3 MiB)
            RX errors 0  dropped 3111  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    root@kali:~# airmon-ng
    PHY     Interface       Driver          Chipset
    phy0    wlan0           ??????          Broadcom 43430
    root@kali:~# lsmod
    Module                  Size  Used by
    ath9k_htc              56142  0
    ath9k_common           21702  1 ath9k_htc
    ath9k_hw              415116  2 ath9k_common,ath9k_htc
    ath                    18741  3 ath9k_common,ath9k_htc,ath9k_hw
    mac80211              532098  1 ath9k_htc
    brcmfmac             2286902  0
    brcmutil                5661  1 brcmfmac
    cfg80211              429089  5 ath,ath9k_common,brcmfmac,mac80211,ath9k_htc
    rfkill                 16082  3 cfg80211
    bcm2835_wdt             3225  0
    bcm2835_gpiomem         2976  0
    uio_pdrv_genirq         3164  0
    uio                     8128  1 uio_pdrv_genirq
    ip_tables              11445  0
    x_tables               13293  1 ip_tables
    ipv6                  347371  20
    root@kali:~# lsusb
    Bus 001 Device 008: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 007: ID 2109:2813 VIA Labs, Inc.
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    The item "VIA Labs" in lsusb is my powered USB hub.

    I have the following but to no avail, I am certainly willing to try them again if they yield any extra information:
    • Plugged in the adapter before and after running "apt-get update && apt-get upgrade -y"
    • Plugged in the adapter before and after running "apt-get dist-upgrade"
    • Plugged in the adapter before and after running "apt-get install kali-linux-full"
    • Plugged in the adapter before and after running "apt-get install firmware-atheros"
    • Plugged in the adapter before and after download and running the raspi-config file supplied by official Raspberry Pi sources to increase the allocated storage space on my SD
    • Plugged the adapter straight into the Pi, circumventing the powered USB hub
    • Done all of the above and rebooting whenever possible
    • Done all of the above and re-imaged and tried a different combinatoin
    • Done all of the above with a different AWUS036NHA adapter
    • Tested both adapters on a Desktop VM running Kali 2017.2 64-bit and both worked perfectly.

    At this point I would be over the moon if I was told that the AWUS036NHA model was incompatible with the current Raspberry Pi 3 Model B and/or the current supplied image so any response at all is highly appreciated.
    Last edited by ExecutiveArka; 2017-10-07 at 08:35 AM.

  2. #2
    Junior Member
    Join Date
    Oct 2017
    Interesting, I am in the same condition exactly same issue with Pi3 and Alfa USB Wifi adaptor.
    Let's see if somebody already solved this matter.

  3. #3
    Senior Member
    Join Date
    Nov 2015
    Mine works like charm.
    I installed the atheros-firmware via:

    apt install firmware-atheros
    Plugged the adapter in and it's purring like a kitten. Monitor mode, frame injection, the whole shebang.

    Just install the firmware and give it another try.
    Please let us know how you go.

    Here a list of the adapters that are confirmed to work:
    Last edited by re4son; 2017-10-14 at 12:06 PM. Reason: Add list
    Check out "Sticky Fingers Kali-Pi":

    Now with mana-toolkit and more goodies!

  4. #4
    I don't really know why it suddenly works but it works like a charm. When I started from a fresh image, instead of running
    apt-get update && apt-get upgrade -y
    I ran
    apt-get firmware-atheros
    as my first command, rebooted and everything was perfect.

    Hopefully that helps people in the future and thank you for your replies.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts