Results 1 to 2 of 2

Thread: No Internal Audio Devices Listed

  1. #1
    Join Date
    2016-Dec
    Posts
    5

    Exclamation No Internal Audio Devices Listed

    Currently, my laptop has a built in microphone and speaker system, neither of which is being detected by Kali. I have tried plugging in an external microphone which is detected but produces no sound on applications like Discord and other VoIP apps.

    When investigating my internals, I use pulseaudio which also doesn't list either of the internal micrphone or speaker.

    I have absolutely no idea how to go about fixing this as I've read every forum post about these types of issues and nothing has worked.
    Here are some output dumps:

    lspci audio:
    Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
    Subsystem: Dell Wildcat Point-LP High Definition Audio Controller
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 32, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 5
    Region 0: Memory at f7210000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: snd_hda_intel

    Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
    Subsystem: Dell Broadwell-U Audio Controller
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at f7214000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: snd_hda_intel

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    867
    sudo systemctl --user enable pulseaudio && sudo systemctl --user start pulseaudio

Similar Threads

  1. Replies: 17
    Last Post: 2017-09-23, 12:55
  2. Usb Headset don't appear in sound menu, but listed in lsusb
    By HighPoint in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-06-16, 07:24
  3. 2 versions of same os listed at startup?
    By Xeper in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-06-01, 04:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •