Results 1 to 2 of 2

Thread: [Errno -2] Name or service not known (setoolkit)

  1. #1
    Join Date
    Indianapolis, Indiana

    [Errno -2] Name or service not known (setoolkit)

    Hi, I have Kali 2.0 64-bit on VMware Workstation Player and Windows 10 Host. I am having problems cloning a site with setoolkit. After going through the options, I get to the site cloner (#2) and after entering 2 and pressing enter, I get the error:
    [!] Something went wrong, printing the error: [Errno -2] Name or service not known

    When I start setoolkit, I get this:
    Process Process-3:
    Traceback (most recent call last):
    File "/usr/lib/python2.7/multiprocessing/", line 258, in _bootstrap
    File "/usr/lib/python2.7/multiprocessing/", line 114, in run
    self._target(*self._args, **self._kwargs)
    File "/usr/share/set/src/core/", line 881, in pull_version
    version = urlopen(url).read().rstrip().decode('utf-8')
    File "/usr/lib/python2.7/", line 87, in urlopen
    File "/usr/lib/python2.7/", line 213, in open
    return getattr(self, name)(url)
    File "/usr/lib/python2.7/", line 443, in open_https
    File "/usr/lib/python2.7/", line 1038, in endheaders
    File "/usr/lib/python2.7/", line 882, in _send_output
    File "/usr/lib/python2.7/", line 844, in send
    File "/usr/lib/python2.7/", line 1255, in connect
    File "/usr/lib/python2.7/", line 821, in connect
    self.timeout, self.source_address)
    File "/usr/lib/python2.7/", line 557, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
    IOError: [Errno socket error] [Errno -2] Name or service not known

    Does anyone know how to fix this so I can clone a site? I think I've done it before but on a different Kali installation. I've tried updating setoolkit (#4) but it gives the same error. Please reply with help. Thanks

  2. #2
    Join Date
    Indianapolis, Indiana
    Nevermind, I got it working. I clicked on "Network" in Settings and it said "Network Manager not running." I ran "service network-manager restart" and now it connects to the Internet and Site Cloner works. Super happy!

Similar Threads

  1. OSError: [Errno 2] No such file or directory (Wifite)
    By antecessor in forum General Archive
    Replies: 1
    Last Post: 2016-07-30, 13:48
  2. Replies: 1
    Last Post: 2014-07-22, 04:21
  3. Setoolkit
    By pbm in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-07-01, 18:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts