Hey all,

I have just updated my old Nexus 7 2013 (WiFi only)
from nethunter 1.0 (Android 4.4.4) to 3.0. And flashed Android 6.0.1 using the linux toolkit
I'm unlocked, TWRP installed, aroma installer flashed everything with no errors and root works etc.

Looked like everything got a nice upgrade with no issues. Until I tried the one and only thing I will use with it, a WiFi adapter for wireless penn tests.

Used to show up fine using this OTG adapter https://www.amazon.com/dp/B00GM0OZ4O/
And my TP-Link TL-WN722N (Atheros AR9271)

but now I get no love, doesn't even show in dmesg, or lsusb.

Also tried a few y-cables and the y-cable support switch in software in case it was a power issue. But it never was before with the exact same hardware?
Its the reason I used that adapter, it was light on power draw and didn't need a powered OTG adapter.

So obviously something is new and different in the software/drivers OTG implementation that I can't figure out.

Anybody know what I could do to get this working again?