Results 1 to 7 of 7

Thread: No Network Founds in Kali Linux Live on MicroSD

  1. #1
    Join Date
    2017-Sep
    Posts
    9

    No Network Founds in Kali Linux Live on MicroSD

    Hello everyone,

    I have mounted Kali Linux in Live mode without persistence on a MicroSD.
    Computer model: MacBook Pro with OS X Yosemiten 10.10.5
    Kali Linux Version: kali-linux-2017.1-amd64

    Problem: Kali does not recognize any ethernet/wifi connection.
    I have read your guide on how to create a post and to give useful informations about the system status.
    For this reason, I have uploaded on imgur the outputs of many useful commands, such as: uname, route, network interfaces, lspci, lsusb, airmon-zc, rfkill and more. Link here: https://imgur.com/a/3k9D4

    What am I missing?

    Thank you in advance

  2. #2
    Join Date
    2016-Dec
    Posts
    150
    I'll save some time for everybody, it's a Broadcom 4360.
    Just fyi, airmon-zc doesn't exist anymore, it's been renamed to airmon-ng a long time ago. A lot of others commands are useless. And your kali is out of date, run apt-get update then apt-get dist-upgrade

    Now, look up "Broadcom 4360 debian" to find out how to use it in kali.

  3. #3
    Join Date
    2017-Sep
    Posts
    9
    Hi, thank you for your answer.

    I have discovered that my Broadcom 4360 can be used if driver wl is installed.
    https://unix.stackexchange.com/quest...on-macbook-pro

    However, I'm stuck at the end of the process. When I do "modprobe wl", I get "FATAL: Module wl not found in directory /lib/modules/4.9.0-kali3-amd64".

    I've read that a possible workaround is to manually download the kali kbuild and headers, but I am not able to find those files for version 4.9.0, which is my kali version. Also, I tried apt-get update && apt-get upgrade, but after a couple of hours kali is still 4.9.0.

    I thought it was a good idea to upgrade to 4.13 and then download the header files for 4.13.
    In this other post, the author suggest to download the header files for 4.3.0, but I can't find them either. It looks like kali repos have only 4.11, 4.12 & 4.13.

    What could I try?

    UPDATE: post I was mentioning is:
    https://forums.kali.org/showthread.p...sistence-Users
    Last edited by maiki; 2017-10-24 at 08:36. Reason: Merge posts

  4. #4
    Join Date
    2016-Dec
    Posts
    150
    You can't use header from 4.3 for 4.13. You need to use the exact headers for your kernel. I hope you downloaded the headers through apt-get.

    Show the error you get when building//installing wl.

  5. #5
    Join Date
    2017-Sep
    Posts
    9
    Quote Originally Posted by Mister_X View Post
    You can't use header from 4.3 for 4.13. You need to use the exact headers for your kernel. I hope you downloaded the headers through apt-get.
    Show the error you get when building//installing wl.
    Mr. X, actually I used wget and then dpkg. Is it wrong?
    To install wl, I did apt-get install broadcom-sta-dkms. That is supposed to provide wl. In my case, I have:

    /lib/modules/4.13.0-kali1-amd64/updates/dkms/wl.ko

    but my kernel is 4.9.0. Not 4.13. However, I can't find 4.9 build and header files in kali repos anymore. Is it possible that the only way to proceed is to download a newer version of kali? That way, I will be able to download header files for 4.13, since they're available in kali main pool.
    Last edited by krats; 2017-11-08 at 20:28.

  6. #6
    Join Date
    2017-Sep
    Posts
    9
    Quote Originally Posted by krats View Post
    Mr. X, actually I used wget and then dpkg. Is it wrong?
    To install wl, I did apt-get install broadcom-sta-dkms. That is supposed to provide wl. In my case, I have:

    /lib/modules/4.13.0-kali1-amd64/updates/dkms/wl.ko

    but my kernel is 4.9.0. Not 4.13. However, I can't find 4.13 build and header files in kali repos anymore. Is it possible that the only way to proceed is to download a newer version of kali? That way, I will be able to download header files for 4.13, since they're available in kali main pool.
    Solved.
    There was no way to get the right header files for my old version of kali. I have remounted kali latest version on the SD, and the headers for 4.12 did the job. wk driver installed and WiFi working.
    I'm a happy man.
    Thank you all.

  7. #7
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    868
    Quote Originally Posted by krats View Post
    Solved.
    There was no way to get the right header files for my old version of kali. I have remounted kali latest version on the SD, and the headers for 4.12 did the job. wk driver installed and WiFi working.
    I'm a happy man.
    Thank you all.
    You should post the solution here.

Similar Threads

  1. Raspberry Pi 3 + WiFi = Corrupt MicroSD
    By Akshunhiro in forum ARM Archive
    Replies: 1
    Last Post: 2016-08-15, 08:43
  2. Formatting a 64G SDXC microsd card for Kali on RPi2
    By flynn's-arcade in forum ARM Archive
    Replies: 1
    Last Post: 2016-08-04, 06:23
  3. Replies: 0
    Last Post: 2015-04-06, 07:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •