Results 1 to 2 of 2

Thread: USB Wifi Adapter AC1200 EW7822UAC (chipset rtl8812au)

  1. #1
    Join Date

    USB Wifi Adapter AC1200 EW7822UAC (chipset rtl8812au)


    I was following tutorial from edimax on how to install this adapter on linux but it does not work for me.

    1. problem was "Package 'linux-headers-generic' has no installation candidate", I ignored it and go forward.
    2. problem was missing dkms, I installed it somehow.
    3. now, after changed platform versin in Makefile to ARM_RPI I get following error
    DKMS make.log for rtl8812AU-4.3.22-beta for kernel 4.4.50+ (armv6l)
    Sat Oct 28 14:08:05 UTC 2017
    make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.4.50+/build M=/var/lib/dkms/rtl8812AU/4.3.22-beta/build  modules
    make[1]: Entering directory '/usr/src/kernel'
      CC [M]  /var/lib/dkms/rtl8812AU/4.3.22-beta/build/core/rtw_cmd.o
    /bin/sh: 1: ./scripts/recordmcount: Exec format error
    scripts/ recipe for target '/var/lib/dkms/rtl8812AU/4.3.22-beta/build/core/rtw_cmd.o' failed
    make[2]: *** [/var/lib/dkms/rtl8812AU/4.3.22-beta/build/core/rtw_cmd.o] Error 2
    Makefile:1402: recipe for target '_module_/var/lib/dkms/rtl8812AU/4.3.22-beta/build' failed
    make[1]: *** [_module_/var/lib/dkms/rtl8812AU/4.3.22-beta/build] Error 2
    make[1]: Leaving directory '/usr/src/kernel'
    Makefile:1576: recipe for target 'modules' failed
    make: *** [modules] Error 2
    I'm running on RPi 1 with kali 2017.2.
    I tryed using all versions from this git repo (4.3.8, 4.3.14, 4.3.20, 4.3.22-beta), always with same error.

    Is it possible to install in this configuration?

  2. #2
    Join Date
    Which git repo are you talking about? There are about 10 of them.

    Have you tried ?

Similar Threads

  1. Replies: 3
    Last Post: 2021-04-08, 22:25
  2. Replies: 2
    Last Post: 2021-01-02, 19:06
  3. Replies: 3
    Last Post: 2018-08-08, 12:32
  4. Replies: 2
    Last Post: 2017-08-14, 14:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts